[v10-develop] Yarn - Rollup - Develop - Docker Issues

Thanks you for all fo the hard work on python 3 and yarn and rollup, but everything is broken.

If you get this to work, its a miracle of trying several things some of which you need to do over and over again. i finally got it working after following 4 different bug threads. Once I got it working i was determined to recreate a clean docker build from scratch to help others struggling and now i am stuck again. Could someone please take the time to explain how to build from a clean frappe_docker build. Basically it is impossible and people are closing bug tickets and discuss topics without any consensus or resolution and the community is pretty frustrated. I have also tried to run frappe_docker with bench switch-to-master with no success. Someone please post end to end instructions for either frappe_docker on master branches so we don’t have to deal with the completely broken develop or a way to get develop to build.

I disagree, except migration to python3 on which I’ve some issues all the other u mentioned are working on latest …

About closing post I’ve answered you privately and on github …

one thing should be very clear to you and all people here …this is a volunteer forum …so no one owns you anything …


If this the same issue,
then it still hurts a bit:

Hi joshreeder is correct, my systems are totally bricked! I can’t switch to master due to one error (pymysql.err.IntegrityError: (1048, u"Column ‘translatable’ cannot be null")), and develop has another (Invalid Token “.” in css file when compiling the reports js)

I spent hours yesterday trying to get it working, installed yarn, rollup, and other packages, but I can’t get anything to work. I too followed countless fixes, the only one I couldn’t try is that package.json-lock that someone posted.

As to josh and/or me moaning about “free” software, yes agreed but please also consider that ONE “helpful” dev can upload something to brick 100’s or 1000’s of peoples machines (eg, this happened recently with yarn! but I think they revoked his access permissions since!)… and when you add up all that misery, time, and cost, it can be quite a large toll on the community – imagine if some of those people will move on to other software, overall net loss for the project as a whole.

And it’s this dev, that seems to be on the forums saying “hey! brand new build system, let’s have some fun and all debug it together!” which is hard to stomach when you’re not on the same level

I take the whole blame, for not testing the new update on my test servers, etc - but I think a lot of people like me are gravitating towards organisations that test before release themselves (eg, Debian) - as it saves 1000s of man years globally this way.

But having said that, if anyone can help us please, let’s meet in the gitter chat room. I have some PayPal for bounty.

1 Like

Yarn is on develop branch, it has not been merged to master, so it’s better to wait to upgrade on master and yarn must be installed as global so u need to run command as root: npm install -g yarn.

And VM virtual image could be not updated as now we are on 10.1 on both frappe and erpnext

i’m not getting ur point …what are u trying to tell us?

I did apt-get install yarn instead - is that the mistake? I’ll try your command now, thank you

so, problem here is not frappe, bench working on not …problem is knowledge …sorry to say that, but you cannot state it’s not working because of issues while it has not been installed properly …

Yes indeed. When I ran bench update I would have loved to have seen Warning: New build system, are you sure?. But instead, I lacked the knowledge, and ran the command… which then bricked my system.

I just tried npm install -g yarn as root, and re-run bench update as frappe user. No change, same error.

I’m totally stuck.

Arguable as develop version is for developers, u just couldn’t update …

Can you share your error trace?

My hunch is, because it’s getting stuck on “.” inside a css file, we’re missing a babel-plugin in the package.json that is provided by bench. And maybe when I try installing packages, they are getting wiped as part of bench update. I’m only guessing, I don’t know. I’m just 8 hours into running a simple “bench update” … lost for ideas… please help us and I am sorry we both appear to be ungrateful…

/home/frappe/frappe-bench/apps/frappe/frappe/public/js/lib/clusterize.min.js, /home/frappe/frappe-bench/apps/frappe/frappe/public/js/lib/frappe-datatable.js, /home/frappe/frappe-bench/apps/frappe/frappe/public/js/frappe/views/reports/report_factory.js, /home/frappe/frappe-bench/apps/frappe/frappe/public/js/frappe/views/reports/report_view.js, /home/frappe/frappe-bench/apps/frappe/frappe/public/js/frappe/views/reports/reportview_footer.html, /home/frappe/frappe-bench/apps/frappe/frappe/public/js/frappe/views/reports/query_report.js, /home/frappe/frappe-bench/apps/frappe/frappe/public/js/frappe/views/reports/grid_report.js, /home/frappe/frappe-bench/apps/frappe/frappe/public/js/frappe/views/reports/print_grid.html, /home/frappe/frappe-bench/apps/frappe/frappe/public/js/frappe/views/reports/print_tree.html → ../../sites/assets/js/report.min.js...
[!] Error: Unexpected token
../../node_modules/frappe-datatable/dist/frappe-datatable.css (4:0)
2: /* variables */
4: .data-table {
6:   /* styling */

npm ERR! Linux 3.16.0-4-amd64
npm ERR! argv "/usr/bin/nodejs" "/usr/bin/npm" "run" "production"
npm ERR! node v6.7.0
npm ERR! npm  v3.10.3
npm ERR! frappe@ production: `FRAPPE_ENV=production rollup -c`
npm ERR! Exit status 1
npm ERR!
npm ERR! Failed at the frappe@ production script 'FRAPPE_ENV=production rollup -c'.
npm ERR! Make sure you have the latest version of node.js and npm installed.
npm ERR! If you do, this is most likely a problem with the frappe package,
npm ERR! not with npm itself.
npm ERR! Tell the author that this fails on your system:
npm ERR!     FRAPPE_ENV=production rollup -c
npm ERR! You can get information on how to open an issue for this project with:
npm ERR!     npm bugs frappe
npm ERR! Or if that isn't available, you can get their info via:
npm ERR!     npm owner ls frappe
npm ERR! There is likely additional logging output above.
npm WARN Local package.json exists, but node_modules missing, did you mean to install?

npm ERR! Please include the following file with any support request:
npm ERR!     /home/frappe/frappe-bench/apps/frappe/npm-debug.log
Bench: Deployment tool for Frappe and ERPNext (https://erpnext.org).
Open source depends on your contributions, so please contribute bug reports, patches, fixes or cash and be a part of the community

I agree. Look at this as an /opportunity/, to add the warning before master branch gets it. This warning would be totally sane, because frappe runs as frappe user usually, and the yarn stuff is a root job.

you seems to not having last version on frappe, try

cd /apps/frappe
git pull

Yes. Will run again now to ensure no errors.

frappe@78b08a83ecaf:~/frappe-bench$ bench update --requirements
INFO:bench.utils:./env/bin/pip install Pillow
Requirement already satisfied: Pillow in ./env/lib/python2.7/site-packages
Requirement already satisfied: olefile in ./env/lib/python2.7/site-packages (from Pillow)
Updating Python libraries...
INFO:bench.utils:./env/bin/pip install --upgrade pip
Requirement already up-to-date: pip in ./env/lib/python2.7/site-packages
INFO:bench.utils:./env/bin/pip install -q -r /home/frappe/bench-repo/requirements.txt
INFO:bench.utils:./env/bin/pip install -q -r ./apps/frappe/requirements.txt
INFO:bench.utils:./env/bin/pip install -q -r ./apps/erpnext/requirements.txt
Updating node libraries...
INFO:bench.utils:npm install
npm WARN optional Skipping failed optional dependency /chokidar/fsevents:
npm WARN notsup Not compatible with your operating system or architecture: fsevents@1.1.3
npm WARN frappe@ No description
Bench: Deployment tool for Frappe and ERPNext (https://erpnext.org).
Open source depends on your contributions, so please contribute bug reports, patches, fixes or cash and be a part of the community

Isn’t frappe based on python 3? It mentions 2.7 in my logs…

No it’s still 2.7 …

are you on docker image?

Yes, the official one

so you’re in on develop branch of bench repo, that’s why it’s not working …