V10 User Permissions Problem

Here is what I did…

My live production system was operating just fine. Then It was decided that one of the users needed to be denied access to the Standard Buying Price List.

I went to User Permissions (there were no entries here yet) and I created a set of user permissions for this user that allowed him access to all prices lists EXCEPT the Standard Buying Price List.

I saved these User Permissions and thought my job was done!

Immediately afterward, suddenly the rest of the users were no longer allowed into the POS module to sell things in the store. They kept getting a pop-up message when they entered the POS module that said Not Permitted (see below)

I thought to myself that I must have done something wrong. So, I went back to the user permissions screen and deleted the new user permissions I had created for the one user that we tried to deny access to the buying price list. I then rebooted the system completely.

Now all of the users are still getting the Not Permitted pop-up window!

What happened when I created the first User Permission?

Why did it destroy everyone elses ability to use the system?

Is there any way to get back to the condition BEFORE I made up a user permission for one user?

Why can I NOT simply get back to normal by deleting the offending User permissions I created for the one user?

Do I have a path forward to making my system work properly again?

Please help.


You need to go to the role permissions manager and uncheck the Apply user permissions box for each of the documents types affected in the roles.

The permissions manager in ERPNext is currently very inintuitive, I believe @rmehta is working on simplifying it.



Unfortunately, I have no idea what document types are required for a POS user to sell things in the store.

Is there a place where I can find the DOC Types related to using POS?

Also, is there no way to get back to the condition before I made the first User Permission?


Short cut…go and check all the roles you assigned to the PoS users.

Check all documents

uncheck the Apply user permissions box where checked



Awesome. That seems to have gotten me out of the short term trouble. I guess i will have to figure out the rest later.