[v11] custom field - not found by 'Global Search'

I am creating a custom field (data) in the customer Doctype.
I have checked the In Global Search box as below …

… but still the content of that field is not found when I use the Global Search


can someone advise how to get over this?

There is a bench command that starts to index your records. I’ve used it a couple of times and it’s worked well.

  1. I guess you saw this coming … do you remember which bench command exactly?
    just went through bench --help, but nothing really rings a bell
  2. would the indexing start at some point automatically?

hi, maybe you just need bench clear-cache or bench clear-website-cache(i am not sure) and clear the cache in the browser

thanks for the hint. It didn’t work though unfortunately

and which version do you use? I’ll try to replicate on my side

v11 (staging branch)

it seems it a related to the content of that field

I am in a Chinese/English bilingual environment and my usecase is to have the translated customer name. Let’s say the customer is a chines company we’ll have the Chinese Characters in the customer_name field and the Translate English Name in the custom field (witch is labelled Translated Name).

As long as it is this way around (Chinese Characters in the customer_name field & English in the custom field) the Global Search will find both strings.

Just when Chinese Characters are in the custom field translated Name the Global Search does not find it.

1 Like

hmmm, I am not sure)) I’ve just tried

I have ERPNext v11.0.3-beta.21 () (staging) and Frappe v11.0.3-beta.26 () (staging)

I use English, I created new Customer Danny Vargas with Translated Name Hogan and didn’t receive any result) neither for Danny Vargas nor Hogan :slight_smile:

here is what I get when the default customer_name has the Chinese Characters “试试客户” and the custom field translated_name has the englisch test customer (which is also the string I am searching for in the Global Search

This does not really make sense to me as I would assume everything is on utf8 and likewise should be able to recognize any sort of characters?

I agree with you but not sure if it works.

and sorry, I don’t know why but from my side it doesn’t show Translated Name in search dialog and didn’t give me any result if I search test customer

Found it :wink:

bench --site [sitename] rebuild-global-search


and yes it should be on the bench help too :wink: A very useful command !