[v12] I keep getting "scheduler inactive" errors

Continuing the discussion from Scheduler Inactive:

I keep getting "scheduler inactive" Errors even though I have executed the
bench --site [site_name] enable-scheduler
command a couple of times.

can anybody advise how this can be resolved?

(also tried bench scheduler --site [site_name] enable with the same result)

bench --site [site_name] enable-scheduler works for me - says scheduler enabled.

I have actually another related problem - it seems the scheduler keeps running a wkhtmltopdf task every 4 min to access a public file as per the nginx access logs. is there a list of scheduled tasks that can be viewed / edited?

@vrms try bench --site [site_name] scheduler enable. This is what works for me.

1 Like

it says the same in the Terminal for me.
Just in the browser the error message keep popping up nevertheless

also returns “Scheduler enabled for site” let’s see how that makes the errors go away

still the error messages are popping up in the browser (even though cli said “Scheduler enabled”)

@vrms i think your issue may be related to this PR:


so that has been fixed into develop apparently.

Isn’t that falling way to short to leave users of the stable branches with this bug until a new version eventually is being released and they may upgrade to that new version-13 release (which nobody can forsee when that will be)? Correct me, whether I am seeing something wrong here.

This PR just allows you to reactivate the scheduler through the UI, so it won’t solve this particular issue.

Do you have the scheduler deactivated in a site_config file anywhere?

Otherwise, the scheduler may be properly enabled, but the notification is being improperly sent. What is the output of bench doctor?


thanks for the pointer.

changed the "pause_scheduler": 1, to "pause_scheduler": 0, in common_sites_config.json based on that which let the scheduler paused (not the exact wording) from bench doctor go away.

any idea where that ("pause_scheduler": 1,) may have come from and how to avoid it in the future that it’s being set to 1 without actively doing that?


as i have the pause_scheduler to 1 then also i have showing error when i am uploding the data as i have disable in development mode this might be the issue not allowing to upload excel file ?

I have the Frappe Framework: v14.15.0 (version-14)

Do you found a solutions?

I try “bench --site YYY.XX enable-scheduler”, but the scheduling are disabled yet.

ubuntu@d:~/frappe-bench$ bench doctor
-----Checking scheduler status-----
Scheduler paused for YYY.XX
vav.hol.es: frappe.conf.pause_scheduler is SET
Scheduler inactive for YYY.XX
Workers online: 3

only found this page about it, is only a discussion about it.


bench --site [site_name] set-config pause_scheduler 0


This worked for me. Thank you!

Thank you very much. This solved my issue!