[v12] Modules don't show on desk

I’m on v12 both frappe and erpnext.
For some users I don’t see for example HR card on desk. I can select show/hide cards and select HR (in other words it is visible in the show/hide pop-up), but it will not show on desk. I removed all custom permissions and also assigned all modules to this user, still nothing.

Any ideas?


I am having a similar problem with v12. I hid some modules. If I activate them now through Show / Hide cards, they don’t show up in the deskview anymore.

Are more people having similar issues or both issues and solutions?

1 Like

Hello @nando, @bedo

Im facing the same problem, was there a solution to this?

Yeps guys, i also sometimes face this issue.
Unfortunately my solution is to create new user with same role as before :grimacing:.
Hope can find real solution here.

1 Like

I am having the same problem for the mean time i create new user with same rights… but im facing one more problem in workflow… some user are able to see the workflow button in form but some user with the same rights and permissions are not able to see the workflow button…

Is the Domain a module is bound to enabled?

Yes the enabled domains are “Services” and “Manufacturing” and all other user with having the same module access are able to see the modules except some users …

Any updates on this? We still see this happening from time to time when cards are hidden and then later added that they do not show up. Resetting the modules settings also seems to have no impact.

1 Like

There seems to be a block_modules in field in User doctype. You could check in tabBlock Module or see the User doc for entries in block_modules field which is hidden, so check with js.

Thanks, I have checked the block modules and removed them, but still does not show up…

1 Like

Go to the doctype and tick Cutome?

Any solution to this ??

1 Like

have the same problem after bench update, only website module is visible. any solution?

1 Like

Same here with a fresh installation, set up everything according to the official docs. Also tried different users. Direct access via URL works.

What I found to be helpful (not nice, but works) is this:

Log in to your console on the server:

$ cd /home/frappe/frappe-bench
$ bench console
> home_settings = frappe.cache().hget('home_settings', 'Administrator')
> frappe.cache().hset('home_settings', 'your.name@example.com', home_settings)
> exit

This will copy the settings from the Administrator role and enable all icons…

1 Like

For me even the Administrator doesnot have any icons. Does it still help? Do we have to do it for all the users?

for me account module not visible for admin user

If you have no icons at all, this might be another issue. Do you have a screenshot or error trace?

The above solution will display all modules (in case an app is added later than users have changed their hidden modules and cannot reset this)…

I had the same problem and I solved it with editing the database - table tabUser - column home_settings
For Administrator it should be:
{“modules_by_category”: {“Modules”: [“Getting Started”, “Accounts”, “Selling”, “Buying”, “Stock”, “Assets”, “Projects”, “CRM”, “Support”, “HR”, “Quality Management”]}, “hidden_modules”: []}

After that commit and restart the ERP and then you can edit the user from “allowed modules” again.