V12 Print Format Builder - IndexError: list index out of range

Running on erpnext v12.1.1 and experiencing this issue when trying to edit and save a custom print format with the print format builder.

IndexError: list index out of range

Here’s what comes up in frappe.log

Form Dict: {
 "cmd": "frappe.client.set_value",
 "doctype": "Print Format",
 "fieldname": "format_data",
 "name": "Booking confirmation",
 "value": "[{\"fieldname\":\"print_heading_template\",\"fieldtype\":\"Custom HTML\",\"options\":\"<div class=\\\"print-heading\\\">\\t\\t\\t\\t<h2>Bo$
Request Error
Traceback (most recent call last):
  File "/home/frappe/frappe-bench/apps/frappe/frappe/app.py", line 60, in application
    response = frappe.api.handle()
  File "/home/frappe/frappe-bench/apps/frappe/frappe/api.py", line 55, in handle
    return frappe.handler.handle()
  File "/home/frappe/frappe-bench/apps/frappe/frappe/handler.py", line 21, in handle
    data = execute_cmd(cmd)
  File "/home/frappe/frappe-bench/apps/frappe/frappe/handler.py", line 56, in execute_cmd
    return frappe.call(method, **frappe.form_dict)
  File "/home/frappe/frappe-bench/apps/frappe/frappe/__init__.py", line 1036, in call
    return fn(*args, **newargs)
  File "/home/frappe/frappe-bench/apps/frappe/frappe/client.py", line 122, in set_value
    child = doc.getone({"doctype": doctype, "name": name})
  File "/home/frappe/frappe-bench/apps/frappe/frappe/model/base_document.py", line 130, in getone
    return self.get(key, filters=filters, limit=1)[0]
IndexError: list index out of range

Anyone else has this issue ?

Reported on github here: v12 Print Format Builder - IndexError: list index out of range · Issue #13458 · frappe/frappe · GitHub

Can you give code snippet here?

Sorry I am not sure what code snippet you are talking about … this is just a normal print format created out of the event doctype.

This continues to be an issue and a potential bug - anyone has any information ?

Hi @Iulian_Olaru

Did you find a solution to this? Just encountered the same error!


Couldn’t find the bug nor the solution.

But I worked around it by creating a new print format and that one works very well and the error does not appear anymore.

1 Like

Great, thanks! Was just considering doing exactly that! :blush:

Kind regards,