V13 routing: Setting a default workspace

Hello together,
I would like to have my custom workspace as “default” workspace that also gets shown, when a user clicks on the Logo on the top left.
The href of the logo per default redirects to “/app”, but in fact you are getting redirected to “/app/home”.

I have also tried to set “Developer Mode Only” for the “Home” workspace (in an environment, which is not in Dev-Mode :wink: ), but then the “Build” workspace will get shown. In addition I have set within my workspace “Is Standard” as well as “Pin To Top”.

Next, I have tried to set a redirect within the Website Settings, but this only redirects, when a User has tried to acces /app/home directly.

Any ideas? Has somebody the same issue?

While checking the code, I have seen an “add_home_page” method, that sounds interesting hear-by.

But in fact, also within the nested methods, at some point eg. the “home” page based on the Roles gets evaluated. I have also tried to set my workspace within the Role as “home”, but this also didn’ solved the issue…

This is a quick thought. I have not checked this out.

When creating a Workspace, there is an option Extends Another Page.
When you check this option, the Is Default checkbox appears.


Hi @Joseph_Marie_Alba1,
thanks for providing that input - almost perfect!

As you have proposed, I have set “Extends Another Page”, then the “Is Default” checkbox appears and I can specify which workspace-page I want to “Extend” (eg. “Home”).

To make it perfect, I am now looking for how to change the label from my default workspace from “Home” to the name I have given when creating the workspace (it shows “Home” even while my workspace has a different name - but I guess, that this is the intentional behavior, so that there is at any time a workspace called “Home”).

Is this the way for v14 as well?

1 Like