V14 Latest Release - No module named 'filelock'

Dear Team,

We have updated the latest release of Frappe/ERPNext

bench --site site_name migrate

Traceback (most recent call last):
File “/home/irsaa/frappe-bench/apps/frappe/frappe/utils/bench_helper.py”, line 71, in get_app_commands
app_command_module = importlib.import_module(app + “.commands”)
File “/usr/lib/python3.10/importlib/init.py”, line 126, in import_module
return _bootstrap._gcd_import(name[level:], package, level)
File “”, line 1050, in _gcd_import
File “”, line 1027, in _find_and_load
File “”, line 1006, in _find_and_load_unlocked
File “”, line 688, in _load_unlocked
File “”, line 883, in exec_module
File “”, line 241, in _call_with_frames_removed
File “/home/irsaa/frappe-bench/apps/frappe/frappe/commands/init.py”, line 127, in
commands = get_commands()
File “/home/irsaa/frappe-bench/apps/frappe/frappe/commands/init.py”, line 109, in get_commands
from .redis_utils import commands as redis_commands
File “/home/irsaa/frappe-bench/apps/frappe/frappe/commands/redis_utils.py”, line 6, in
from frappe.installer import update_site_config
File “/home/irsaa/frappe-bench/apps/frappe/frappe/installer.py”, line 19, in
from frappe.utils.synchronization import filelock
File “/home/irsaa/frappe-bench/apps/frappe/frappe/utils/synchronization.py”, line 6, in
from filelock import FileLock as _StrongFileLock
ModuleNotFoundError: No module named ‘filelock’
Usage: bench [OPTIONS] COMMAND [ARGS]…
Try ‘bench --help’ for help.

same error on bench version

You probably just pulled the code and not bench update.

New packages won’t get installed if you manually migrate like this.

I tried to bench update

It gives me same error

Any solutions? got stuck

bench pip install filelock~=3.8.0

to manually install it or

bench setup requirements also works.

1 Like

@ankush Resolved !!

Thank you so much