V14 not working when accessed from iPhone or Android


I successfully installed ERPnext 14 on Debian 10. The production server runs without any warnings or errors and I’m successfully using it from laptops / PCs.

However, when I try to access the site using a mobile device (iPhone or Android!) , I get to the login page. After successfully logging in, only a page with the “E” logo is shown, without anything else. It’s the same when it request the “desktop site” from the mobile device.

Is this a known issue with 14?


facing same issue.

This happens with safari browsers mostly on iOS. Try using any other browser and you should be able to access the app without issues.

On iOS, there’s no difference between any of the browsers. They all use the same WebKit engine.

But again: even switching to Android and trying various browsers (Firefox, Chrome) doesn’t help. It appears to be an actual bug, not just an incompatibility with eg JavaScript.


First, welcome to ERPNext community :slightly_smiling_face:.

Have you tried clearing the browser cache for Android? It might be a cache problem.

Thanks for the warm welcome :pray:

Yes, I have tried clearing the cache. In fact, I have tried it on 10+ devices of colleagues just to make sure it’s not specific to one device / OS / browser.

hi @Daniel_Gehriger

Is it checked or unchecked under System Setting > Security > Allow only one session per user ?

@centaur : it’s unchecked. But I now suspect the entire issue is rather related to Invalid or unexpected token prevent accessing ERPNext Desk · Issue #17793 · frappe/frappe · GitHub. Because, out of the blue, the site no longer works either even when accessed from a desktop computer.

I can access it through non-SSL (http), but run into the above issue when using SSL. The weird thing is that this started w/o any change to the server. I even restored it to a known working backup.

So I’ll first try to find a fix for the above issue before further investigating the mobile device access.

Please disregard this thread. The underlying problem was indeed Invalid or unexpected token prevent accessing ERPNext Desk · Issue #17793 · frappe/frappe · GitHub. After resetting ERPnext the v14 (non-development!), recreating the site, and restoring it from the backup DB, all seems to be working again.

I still don’t know why it stopped working though.

1 Like

Did you try to contact someone responsible for this app? If you can’t figure it out by yourself, I suggest you better call for professional help. Also, I found on the internet that such problems could appear while using Safari internet. If you want to run it, download another browser that won’t have so many security problems. You can try solving this problem yourself, but it is not as easy as you think. Visit zumroad.com for more information. You won’t be disappointed.