V14 unable to see workspace sidebar


I migrated a site from v13 to v14 by setting a new server with version-14 and doing a backup restore. After restoring backup I ran bench migrate and could see a lot of patches got applied.

However, after login I’m unable to see workspace sidebar although I have system manager role and have all the modules checked under Allow Modules section of user page.

Any hints on where to look for? I checked system settings but couldn’t find anything that would hide the sidebar.

1 Like

It got resolved for user without System Manager Role. But unsure of what solved it. (Could be due to running bench migrate multiple times, but seems superstitious, though).

The issue still remains for Administrator user although the user has System Manager Role.

Exact same issue here. Been 2 days running in circles…

Did you follow the migration guide, especially for workspaces?

Go into your Role from Role list, there you can enable whether to show Sidebar, Search bar etc. Of course the role being the role assigned to the user.

What OS/browser are you using?

I’ve found on older Apple systems using Safari or Firefox (iOS12 and macOS High Sierra) that the sidebar is not visible

1 Like

@Patrick.St The issue is that the sidebar itself doesn’t appear for Administrator user. Other users were able to see it.

@iMoshi I checked that and there’s nothing hidden for System Administrator role

@pmjd You’re absolutely right. The issue happens in firefox only. I was using firefox and chrome simultaneously to check Administrator and non-admin logins. Coincidently, never tried Administrator user on chrome, so came to believe that something’s wrong with Administrator login.

P.S. For some reason I’m not seeing an option to mark an accepted answer.

1 Like

Confirming the problem is with firefox, not in Brave (chrome)

Ubuntu 22.04
Firefox 109.0 (snap install. Having lethargic startup issues with snap. Will do manual install and check if anything changes.)
canonical-002 - 1.0

I see the issue in Firefox 109.0 & 109.0.1 on windows 10.

Hi, just to note that on Windows 11, firefox 109.0.1 (64-bit) works fine. The issue seems to be either on linux systems or something related to snap.


ERPNext: v14.27.0 (version-14)
Frappe Framework: v14.38.0 (version-14)

I have tested and found that issue in System Manager and Workspace Manager Role.

I created one user with all permission except System Manager and Workspace Manager then Workspace Sidebar appeared.

1 Like