[V7] Email incoming not working

in V6, this setting is working, but when i upgrade to V7, incoming is not working.

Can any support to fix this?

1 Like

Can you check your scheduler logs?

Traceback (innermost last): File "/home/frappe/frappe-bench/apps/frappe/frappe/email/receive.py", line 70, in connect_pop self.pop = Timed_POP3(self.settings.host, timeout=frappe.conf.get("pop_timeout")) File "/home/frappe/frappe-bench/apps/frappe/frappe/email/receive.py", line 400, in __init__ self._super.__init__(self, *args, **kwargs) File "/usr/lib64/python2.7/poplib.py", line 89, in __init__ self.sock = socket.create_connection((host, port), timeout) File "/usr/lib64/python2.7/socket.py", line 571, in create_connection raise err error: [Errno 110] Connection timed out

[Errno 110] Connection timed out Traceback (innermost last): File "/home/frappe/frappe-bench/apps/frappe/frappe/email/bulk.py", line 294, in send_one smtpserver.sess.sendmail(email["sender"], email["recipient"], encode(email["message"])) File "/home/frappe/frappe-bench/apps/frappe/frappe/email/smtp.py", line 158, in sess cint(self.port) or None) File "/usr/lib64/python2.7/smtplib.py", line 255, in __init__ (code, msg) = self.connect(host, port) File "/usr/lib64/python2.7/smtplib.py", line 315, in connect self.sock = self._get_socket(host, port, self.timeout) File "/usr/lib64/python2.7/smtplib.py", line 290, in _get_socket return socket.create_connection((host, port), timeout) File "/usr/lib64/python2.7/socket.py", line 571, in create_connection raise err ValidationError: [Errno 110] Connection timed out

@Gavin_Ji Seems like your inmotionhosting port or firewall issue. Can you verify with your server vendor.

telnet mankem.com 25
Connected to mankem.com.
Escape character is '^]'.
220-vps11825.inmotionhosting.com ESMTP Exim 4.87 #1 Sat, 30 Jul 2016 23:49:09 +0800 
220-We do not authorize the use of this system to transport unsolicited, 
220 and/or bulk e-mail.
421 vps11825.inmotionhosting.com: SMTP command timeout - closing connection
Connection closed by foreign host.

I contacted inmotionhost server provider, and IP: is not blocked, my setting is also correct. it may be an issue with that python script we’re using to try to send email/receive.
In fact, in V6, the same setting, email incoming function was working well.

anyone can do some help?

today i checked with inmotionhost. they checked for me and replied:

emails on server that the logins are working:
Aug 1 11:47:21 vps11825 dovecot: imap-login: Login: user=sales@mankem.com, method=PLAIN, rip=, lip=, mpid=9192, session=
Aug 1 11:48:17 vps11825 dovecot: imap-login: Login: user=hr@mankem.com, method=PLAIN, rip=, lip=, mpid=9244, session=
Aug 1 11:49:57 vps11825 dovecot: imap-login: Login: user=service@mankem.com, method=PLAIN, rip=, lip=, mpid=9273, session=

i can share login details, and server details, can anyone check for me, and tell me how to solve this issue?

After trying everything (Gmail, ZOHO, Postfix, SSMTP, Amazon SES) for weeks. Today, I did the following but can’t point to what worked, but its working:

  1. I deleted the notifications account
  2. Cleared the scheduler jobs with bench purge-jobs
  3. (Re)started the scheduler bench enable-scheduler
  4. used SendPost as a relay

All is worked so far. Unfortunately I cant zero down to the exact solution.

A little info

I’m hosted on AWS
Ubuntu 14.04
Ports, inbound and outbound opened (AMAZON)
Frappe & ERPNext 7.x

1 Like