V7 Fresh Install Error

Hi Team,
Getting this error on fresh install.

@vjFaLk @shreyasp

Hi, can you tell us what OS and Version you’re using so we can try to recreate this?

i got the same error, how to solve this?
Ubuntu 14.04.4 LTS (GNU/Linux 4.4.0-28-generic x86_64)

I just ran install on Ubuntu 14.04.4, but it didn’t throw any issues. It’s possible there was something wrong with the download server for some duration of time.

I have the same error on Cent OS 7…


I’m using CentOS 7, all patched up to date.

Retried, getting passed the above error but failing at TASK [Install nodejs v5]
I could attach the full log but it’s too long.

Hi All,

On my fresh install on Ubuntu14 im getting :

WARNING: The following packages cannot be authenticated!
mysql-common mariadb-common libmysqlclient18 libmariadbclient18
mariadb-client-core-10.0 mariadb-client-10.0 mariadb-server-core-10.0
mariadb-server-10.0 libmariadbclient-dev mariadb-server
E: There were unauthenticated packages and -y was used without --allow-unauthenticated

and then it stops

is there something im missing?


What script are you using? What are you installing on, VM / VPS?

Im running these 2 lines… is there a different script to install v7?

wget https://raw.githubusercontent.com/frappe/bench/master/install_scripts/setup_frappe.sh
sudo bash setup_frappe.sh --setup-production

Running on digital ocean.


Hi @hpema108,

This is an old installer that you are trying to use, this will install v6. Please use following readme to install v7 on your digital ocean instance.

Hi @shreyasp

Thanks for that…all installed but is it possible to know restore my latest v6 backup onto v7? Ive tried and get an error

bench --force restore /home/frappe/frappe-bench/sites/site1.local/private/backups/20160724_73942069_database.sql
Traceback (most recent call last):
File “/usr/local/bin/bench”, line 9, in
load_entry_point(‘bench’, ‘console_scripts’, ‘bench’)()
File “/home/frappe/.bench/bench/cli.py”, line 26, in cli
return frappe_cmd()
File “/home/frappe/.bench/bench/cli.py”, line 87, in frappe_cmd
os.chdir(os.path.join(bench_path, ‘sites’))
OSError: [Errno 2] No such file or directory: ‘./sites’


From the error it seems you are trying to run bench restore from a location which is not \home\frappe\frappe-bench and so it is not able to find out your site.

Please run the command from \home\frappe\frappe-bench and after the restoring just run bench migrate to run all v7 patches.

Hi @shreyasp

Thanks for that… I tried the restore - all good, but when I try the migrate command I get this error

File “/home/frappe/frappe-bench/env/local/lib/python2.7/site-packages/MySQLdb/connections.py”, line 36, in defaulterrorhandler
raise errorclass, errorvalue
_mysql_exceptions.ProgrammingError: (1146, “Table ‘1bd3e0294d.tabFee Component’ doesn’t exist”)

This im getting also if I try to do an upgrade fro v6, so looks like something with the migrate command might have a bug?


1 Like

@hpema108 this is fixed in develop

Best to start new threads in a new post.