V7 to v8 upgrade error - npm regenerator-runtime step


I have downloaded the latest Production image from https://erpnext.com/download

Logged in with frappe user and executed:

  • cd frappe-bench
  • bench update
    It warned me that it needs to make major version upgrade from v7 to v8
    So I started:
  • bench update --upgrade

It took some time and when it reached the npm … regenerator-runtime it raised an error and stopped.

I have tried second time. The same error. See the screen shot.

Any help is much appreciated.


try downloading http://build.erpnext.com/ERPNext-Production.ova production image it is on v8 so you will not need to run bench update --upgrade

Thank you @makarand_b.
I’ve downloaded the new image.
But when I try to setup the company and write Company abbreviation on Setup step 4 ( http://localhost:8080/desk#setup-wizard/5 ) I put the text “НИн” (this is in Cyrillic) and it gives me the following error:

Server Error: Please check your server logs or contact tech support.
Traceback (most recent call last):
File “/home/frappe/frappe-bench/apps/frappe/frappe/app.py”, line 56, in application
response = frappe.handler.handle()
File “/home/frappe/frappe-bench/apps/frappe/frappe/handler.py”, line 21, in handle
data = execute_cmd(cmd)
File “/home/frappe/frappe-bench/apps/frappe/frappe/handler.py”, line 52, in execute_cmd
return frappe.call(method, **frappe.form_dict)
File “/home/frappe/frappe-bench/apps/frappe/frappe/init.py”, line 922, in call
return fn(*args, **newargs)
File “/home/frappe/frappe-bench/apps/erpnext/erpnext/accounts/doctype/account/chart_of_accounts/chart_of_accounts.py”, line 108, in get_charts_for_country
if (fname.startswith(country_code) or fname.startswith(country)) and fname.endswith(“.json”):
UnicodeDecodeError: ‘ascii’ codec can’t decode byte 0xc3 in position 19: ordinal not in range(128)

Request Data

“type”: “POST”,
“args”: {
“country”: “Bulgaria”,
“cmd”: “erpnext.accounts.doctype.account.chart_of_accounts.chart_of_accounts.get_charts_for_country”
“url”: “/”
Response JSON


App Versions

“erpnext”: “8.9.0”,
“frappe”: “8.8.0”


Just checked again with latin letters for company name and abbreviation, it still gives some error and the Chart of accounts ID on the next step is empty. I succeeded to finalise the setup after some refreshes, going back and forth, but there is definitely a problem on the step 4 and 5 in the setup wizard.

Related problem: