V9_Data Import Tool

Hello, I am trying to use import data tool to import data from instance for testing ERPNext, But I am facing certain problems while importing – “File upload disconnected”.

Any suggestion please advise, as this is happening in latest version V9. Please find the screenshot as well.


Please share your JS console trace. To show console, press Ctrl + Shift + I

Hope your file size is large.
socketio return this error when file upload prob.
Hope #erpnext Solved this issue ASAP.
Please open a Issue in github.

Hello @mohnish_thakur2003,

Check file size first, if the file size is large then try to import it using the command line.



Hello @yogendrasinh,

My file format is .xlsx. And my file size is only 22 kb.
So, it is only compatible for csv file or it is also support the .xls file?

@mohnish_thakur2003 @Chandresh_Thakkar can you share your JS console?

@rmehta After doing Ctrl+shift+I then Ii am getting this logs as in JS form:

localStorage cleared
desk.min.js?ver=1506493425.0:98 Cleared App Cache.
desk.min.js?ver=1506493425.0:129 localStorage cleared
jquery.min.js:4 [Deprecation] Synchronous XMLHttpRequest on the main thread is deprecated because of its detrimental effects to the end user’s experience. For more help, check https://xhr.spec.whatwg.org/.
send @ jquery.min.js:4

Let me reduce the chunk size and increase the keep-alive timeout. Will push a fix soon.

@rmehta Thank you.

Ok, we will wait for the new update on same.

Thank you for help.

Released a fix on v9.0.2

Hello, Team,

I took the latest pull of erpnext and frappe app with the bench update command.

I am looking that my erpnext version is v9.0.1 and frappe version id v9.0.2.

But still, the issue is not solved.

Thank You.

@nabinhait @rmehta

As per the said words, I have taken the latest pull and updated the site as well, but still, an issue persists. Below is the screenshot for the same.

Seeking the help.thanks for support in advance.


I am also facing the same Issue…

My Java Console is also showing same jquery Depreciation message and data import is giving same error.

Require immediate fix.

1 Like

You may prefer this option https://erpnext.org/erpnext-jobs

So far I have understood that any challenges faced in installation or customization then we should use discussion forum. This is a generic issue with V 9.x.x and I do not want any specific improvement.

I am also facing the same issue and therefore instead of creating a new thread I added my views on the same thread.

Please correct me if I am wrong.

Yes this forum is about sharing, supporting and self help.

But understand that ‘Require immediate fix’ suggest you have no time to research or contribute.

What have you found or tried?

In your case you have the option of ‘professional’ support!

Sorry for inconvenience caused due to my choice of words ‘Require immediate fix’…

I am very new to ERP Next and right now I am focusing more on customizing the existing setup. I have implemented the V8.x.x for one of the organization and after upgrading to V9.x.x File upload and Data import started giving error.

I am also struggling to make it work and believe that I can get some support from the discussion forum. It appears that this error is either due to socket io or some java script. But when I found that others are also facing the same and therefore i also requested. I am looking some kind of fix on this error from the experts in the community.

No apology necessary dgsol.

‘urgent’, ‘production server down’, and ‘your immediate response please’ etc are hot buttons that cross the line from volunteer support to professional support.

Invariably a self search of the forum will turn up clues and pointers.

Support folks joke about this service for a reason

In your case a search on ‘File upload disconnected’ points to this File Upload Disconnected. Please try again

Have you tried that…