Version 11 - Backflushing Raw Materials based on Material Transfer - Bug?

ERPNext: v11.0.3-beta.32 () (staging)
Frappe Framework: v11.0.3-beta.45 () (staging)


We are using ERPnext in our microbrewery, where we manufacture speciality beers. Recipes often change in our manufacturing setup due to seasonality / availability of raw materials. Our BOM provides a “guiding standard recipe”, but the actual raw material consumption often differs due to above reasons.

To make ERPnext work for us, we selected "Backflush Raw Materials based on: Material Transferred for Manufacture". In version 10, this would allow following manufacturing workflow:

  1. Create a new Production Order with “Skip Material Transfer” selected.

  2. Transfer raw materials (Material Transfer for Manufacture) against this Production Order. This would often be 3 - 4 separate transfers, as the production of a beer batch takes about two weeks, and raw materials are added at different stages of the process.

  3. After approx. two weeks when the beer batch is ready, we would open the Production Order and choose “Finish” (for the complete quantity). Then the Stock Entry page would open (Manufacture) and list all raw materials of various stock transfers which were transferred against this production order.

In version 11 the last point changed: Regardless what has been transferred against the Production Order (Work Order), the final Stock Entry (Manufacture) will always suggest the BOM quantities. This is despite all transferred materials show up correctly in Work Order page itself as “Transferred Qty”.

I hope that this is a bug and not new functionality. Because as it works currently, we need to copy the transferred items and quantities from the Work Order page, and manually insert them in the Manufacturing Stock Entry. With pen and paper, which somewhat defies the purpose of an ERP :))

Can someone advise on this problem?



Thanks for posting OSchauf - refer to screenshots here [V11] Backflushing not working · Issue #16265 · frappe/erpnext · GitHub


The problem continues to persist. Effectivly, in Version 11, there is now no difference between the two manufacturing backflushing settings: “BOM” or “Material Transferred for Manufacture”. Our workflow was based on the latter, but since V11 ERPnext seem to use the BOM in both cases.

Did anyone found a workaround for this?



apart from your “backflushing bug” maybe the initiative to implement a so called process manufacturing feature would be interesting for you as well

Did you get this working? I’m having same issue on version 12 as well

@OSchauf did find a work around for this ?

Not working for us as well.

version details:
erpnext 12.13.0
frappe 12.11.0

Neither for us

Did you try on v13?

Yes, I selected two batches for same item using material transfer but when i click on consume material, system give just one line and that too without the batch

Did it worked? I am using version 14 and i have same issue.