Version 15 assets missing after bench setup requirements and bench build

Anyone knows how to handle this?

1 Like


1 Like

Try adding “host_name”: “” to your site config(s) and run bench restart. I’ve also gotten into/out of this problem by solving a permissions problem: sudo chmod o+x /home/[frappe-user]

Okay thanks I will try this

still same error

What is the output of bench version? This seems like an old version mismatch

branch version-15 erpnext frappe

after I did bench build --app frappe --hard-link i got this message

fatal error: all goroutines are asleep - deadlock!

try bench build --app your_app

yes all apps are build successful except frappe

try bench setup requirements

bench setup requirements, migrate, build still the same problem for frappe.
have you try to rerun bench build to your instance?

Try it without the --hard-link argument.
Is this a containerized install of some kind?

its working

version-15 ? how about bench setup requirements? ahm this is the same error when i tried to setup erpnext in docker, after I install my custom app the assets link broken or not found specially website.bundle css

yes same problem

Try running yarn inside /apps/frappe? For whatever reason you’re not getting the dependencies installed that need to be.


This is an esbuild and/or container dependency problem, not a Frappe one. Most likely you do not have Go installed, but I can’t really help with this.