Version 8: Email Domain is not saving

Hi All, I just updated to version 8 a week ago. I still cant seem to save the email domain settings.

  1. In previous version i had, i did not have to provide pop/imap. I dont want this feature. I only want to send notifications.
  2. Once I try to save, it hangs…at saving. Never proceeds beyond it.

Any idea, what is causing it to hang?


Hi @Deepak_Pai, In my case the problem was the Safari version (a javscript error)

Whith de google crhome no problem!

I use google chrome. In any case, I worked around it. But thanks!

What is the workaround. How is this solved. I am on Version 8 too.

I tried Safari and then Chrome too.

In both cases the email setup hangs when i try to create an Email Domain. It says ‘Saving’ and the whole browser is greyed out as though nothing is happening.

Using the VM install i found this same issue too. I found using the ip address instead of the hostname of the mail server worked for me. This indicates there may be an issue with dns resolution in the vm and Frappe but it may at least get you up and running

I think i used microsoft edge or internet explorer. And then it worked.

Should this not be reported as a bug because it seems like a lot of people are having issues

Why is the post being withdrawn…has a solution been found… can you update.


Often the problem is just a stale cache - so be sure to clear your browser and erpnext caches.

It’s easy to overlook the simple fixes :slight_smile:

Of course just restarting the ‘services’ can fix things too.

I am still facing this problem

What is the problem exactly? Have you tried using different browsers? Clearing the cache?

I have reloaded the site as well executed bench cache-clear
still cannot make it work it just freezes

Did you try a different browser?

Try firefox. For me it works.

Solved My service provider blocked ports to avoid spamming


Was anybody able to solve this problem? I tried clearing cache and used Chrome and Firefox but nothing seems to be working.