VM Production ERPNext Error: No module named 'pypika'

I installed the VM Production version of this post:

Everything was working fine until I think it was a good idea to update the bench…

During the processes I got some red errors (that I forget to print) and then the server stop work. When I try to update againt he keeps returning this error:

ModuleNotFoundError: No module named ‘pypika’

I searched for this error in the forum, but found nothing. I’m brand new to this stuff, so I hope I’m not anoying.

Anything I can do to fix that or to return to the previous version without reinstall it all?

Hi @Testa,

Please apply as a command.

./env/bin/pip3 install pypika

Thank You!


It solved this part, but next he acused other:

No module named ‘bleach_allowlist’, which I solved with this posts:
ModuleNotFoundError: No module named ‘bleach_allowlist’

But now it says:
ModuleNotFoundError: No module named ‘tenacity’
Which I found nothing in the forum again…

During the last process he say something about no compatibility with something’s version.


What does: sudo pip3 install pillow return?

Hi @Testa,

Please apply as a command.

./env/bin/pip3 install tenacity

Thank You!

You will have too keep installing all these modules in the same way.
you will land up with many more modules likes this for example - simple_chalk, tweepy, paytmchecksum, razorpay and many more.

u will probably land up with an error for twitter settings - tweepy.error
for which u probably should downgrade to twitter module verison 3.1.0 instead of the latest version.

and even after installing all these modules,I am not sure if u will be able to successfully migrate to version 13. I have been trying this for over two weeks, very little help is available online, even after following the procedures laid out.

you run into to some jsonobject error, some commandfailederror and many more.

you probably cant upgrade to pillow 9 coz it requires python3.7+ and frapper env will be working on python 3.6

so all the very best my dear friend. and if you are able to successfully migrate to v13 please let me know.

So we reach the paradigma that I was unhapply waiting for… It will be easier to just delete everything and start a new working one.

Thanks everyone who tried to help!

Has anyone been able to resolve the pillow 9 / frapper needing python 3.6?
Does not make sense … upgrade path broken or maybe I am getting something wrong?

I was able to update to 13.35.2 by following this guide Cannot install requirements with python 3.8 · Issue #29925 · frappe/erpnext · GitHub.