Wanna try this but No proper documentation found

Wanna try this but No proper documentation found

I am trying to install erpnext wiht frappe in ubuntu 15, but could not do it. very difficult to install and not a good documentation in site

having many issue, like access denied, after 1 day got solve that make all 777 and then stuck on ./localhost/site_config.json does not exist that is in browser,

can’t waste time, if you guy provide a proper doc then it will be good to at least try this.

Have you tried with GitHub - frappe/bench: CLI to manage Multi-tenant deployments for Frappe apps ?

Access denied means you installed with root wich is explicitly mentioned in the documentation:

You need to run this with a user that is not root, but can sudo. If you don’t have such a user, you can search the web for How to add a new user in { your OS } and How to add an existing user to sudoers in { your OS }.

You will get better help if you are less rude, keep in mind that this is Free and Open Source.

Hi Pau

I can understand your point, and followed the doc given i have installed it through root but runing through frappe user. but getting this error

./localhost/site_config.json does not exist in browser

can you help me for this

And this is exactly what documentation and @Pau_Rosello warned you not to do. Read his post more attentively.

If you run it as root check this command:

If you’re logged in as root, use --user flag to create a user and install using that user
sudo python install.py --develop --user frappe

Running as root will cause many problems

"run_travis": false


TASK [include] *****************************************************************
included: /tmp/.bench/playbooks/develop/includes/setup_bench.yml for localhost

TASK [Check if /tmp/.bench exists] *********************************************
fatal: [localhost]: FAILED! => {“failed”: true, “msg”: “The conditional check ‘not without_bench_setup and not run_travis’ failed. The error was: error while evaluating conditional (not without_bench_setup and not run_travis): ‘without_bench_setup’ is undefined\n\nThe error appears to have been in ‘/tmp/.bench/playbooks/develop/ubuntu.yml’: line 95, column 5, but may\nbe elsewhere in the file depending on the exact syntax problem.\n\nThe offending line appears to be:\n\n # setup frappe-bench\n - include: includes/setup_bench.yml\n ^ here\n”}
to retry, use: --limit @develop/install.retry

PLAY RECAP *********************************************************************
localhost : ok=23 changed=5 unreachable=0 failed=1

Traceback (most recent call last):
File “install.py”, line 281, in
File “install.py”, line 99, in install_bench
run_playbook(‘develop/install.yml’, sudo=True, extra_vars=extra_vars)
File “install.py”, line 234, in run_playbook
success = subprocess.check_call(args, cwd=os.path.join(tmp_bench_repo, ‘playbooks’))
File “/usr/lib/python2.7/subprocess.py”, line 540, in check_call
raise CalledProcessError(retcode, cmd)
subprocess.CalledProcessError: Command ‘[‘ansible-playbook’, ‘-c’, ‘local’, ‘develop/install.yml’, ‘-e’, ‘@/tmp/extra_vars.json’, ‘–become’, ‘–become-user=vikash’]’ returned non-zero exit status 2

tried to installed through new user called vikash, but can’t, can you solve it for me

Is this a new machine or the same?

I would suggest to install on new machine as the folder created by root will not be overwritten by this user and you will avoid further problems


you mean new machine that means i need to format my system and tried again ??

This is actaully a new machine

Yes, I was referring to new OS install.

Try to delete this folder /tmp/.bench as the error seems to be in the step called “not without_bench_setup and not run_travis”

i installed it in new OS where nothing about frappe was installed, got the same error, the above one

i don’t know why this happen, i can understand that opensource but opensource provide well doc as a python module there are many problem.

sorry… but very upset.

If you are just interested in trying out ERPNext I would suggest using the production VM found here:


It is already setup, and usually runs with no issues at first start up. It’s a great way to check if ERPNext suits your needs without spending too much time.
If you decide it does, then at least you know it will be worth it to figure out any errors with the help of the very knowledgeable community and great developers here.

I agree that there’s not much documentation specifically about Ubuntu 15. If you decide to use it that would probably be a very appreciated way to contribute back to the community. Open Source projects usually have a much easier time attracting developers than documentation writers.

I htink you are facing same problem here: