We setup erpnext on aws ubuntu 18.04 server but it's not working

Hi, I setup ERPNext on aws ubuntu 18.04 server but it’s not working

We follow this all step as mentioned below link

Can someone guide me for proper installation of erpnext on ubuntu 18.04 with step wise from starting to end. and also install it on local host as well as live on browser.

please share the error or traceback.

Hi Sagar,

Setup is done with subdomain without any error but when i try to run url nothing to show me.

Hi classicus

I had exactly the same problem with AWS. I have had an install on there for 3 years and it has been OK.

I have started some more instances on it recently and I am unable to contact the new URL or the old site.
The security permissions would not stay set to “anywhere”, they kept changing back to custom. I spent 3 days on it. watched hours of training utube stuff. I failed.
They have changed it to provide another level of security. It is very secure, I cant get in to it via http.
I gave up.
Created an instance on Digital ocean and set up a new Erpnext in 15 minutes. It was so simple. Everything works so well.
I could not believe the difference.

Then I opened up a backup of the old site.

A note to other newbies is the starting point at which to down load all files when creating a new instance.
You must be a root user. That means You must be root@… and use sudo commands.
$ sudo -i gets you to root.
Digital Ocean puts you straight in to root@ when you open up.
AWS does not. It puts you in to ubuntu@. If you load the files from there they all go in the wrong place and cause potential days of head scratching.
One more point on digital ocean. When you first ssh in to it you have to provide a password in the email.
You cannot paste this in, you have to type it. when you type it, it does not display, but it is going in. Then you have to confirm it by typing in a second time. its about 20 characters long - boring…

Hope this helps some bods -

written Jan-9-2019 - things can change so quickly!

Hi Crikey,

I am following all steps properly as provided on internet but then after it’s not working on my domain.
Please send me erpnext setup steps for setup in my subdomain.

I followed all the steps on the internet. I could not get it to work with sub domain.
My advice is give up with AWS now!
If you want to continue with AWS, I am not your man to help…

Open a “droplet” with Digital Ocean and you will be up and running in no time.
These are the instructions I have recorded and worked for me on Digital Ocean.
They did not work this smoothly on AWS. I dont know why? And then I could not get in using http after the battle of installing it.

Become root by this

sudo -i - (in the digital ocean droplet you are already root by default)

sudo apt-get update && sudo apt-get dist-upgrade (makes sure ubuntu is up to date)

sudo reboot (just to make sure its happy)

Sudo -i (just to make sure you are in root@)

wget https://raw.githubusercontent.com/frappe/bench/master/playbooks/install.py

sudo apt-get install python-setuptools python-pip

sudo python install.py --production --user frappe

This will install the PRODUCTION program and create a new user called frappe.

It will ask you for a new password for a database and a password for the administrator of the program (the first desktop screen you see after installation.

sudo passwd frappe

sudo chown -R frappe /home/frappe (maybe this is just good measure)

Su frappe (to change user from root@)
-Enter password entered earlier

Navigate to home/frappe/frappe-bench

All bench commands operate from this point using user frappe. You could use bench update for example.

paste your Digital Ocean ip address in to your browser and up comes the “Administrator” login screen. type in the password you created in the setup process and your in.

Happy erping!

We’ve used both Digital Ocean and Linode for Open Source ERP installs (including also other than ERPNext) and both seem to work pretty well.

I have ERPNext instances installed on AWS Ubuntu 18.04 LTS …no issues!

Something might have gone wrong during the original install. Maybe you could try starting afresh with a new instance


Hi Wale,

Can you send me installation step which you followed for setup ERPNext ??

Hi @classicus

The easy install script now works on Ubuntu 18.04 LTS so if you don’t have any bespoke requirements, you can just follow the exact steps outlined in the easy install section on Github:

Be sure to install pre-requisites as well


Hi Wale,

I try steps which you suggest but when i run this command $ bench new-site erp.domainname.com
it’s showing me this errors so please guide me for this

Traceback (most recent call last):
File “/usr/lib/python2.7/runpy.py”, line 174, in _run_module_as_main
main”, fname, loader, pkg_name)
File “/usr/lib/python2.7/runpy.py”, line 72, in _run_code
exec code in run_globals
File “/opt/erpnext/frappe-bench/apps/frappe/frappe/utils/bench_helper.py”, line 97, in
File “/opt/erpnext/frappe-bench/apps/frappe/frappe/utils/bench_helper.py”, line 18, in main
File “/opt/erpnext/frappe-bench/env/local/lib/python2.7/site-packages/click/core.py”, line 764, in call
return self.main(*args, **kwargs)
File “/opt/erpnext/frappe-bench/env/local/lib/python2.7/site-packages/click/core.py”, line 717, in main
rv = self.invoke(ctx)
File “/opt/erpnext/frappe-bench/env/local/lib/python2.7/site-packages/click/core.py”, line 1137, in invoke
return _process_result(sub_ctx.command.invoke(sub_ctx))
File “/opt/erpnext/frappe-bench/env/local/lib/python2.7/site-packages/click/core.py”, line 1137, in invoke
return _process_result(sub_ctx.command.invoke(sub_ctx))
File “/opt/erpnext/frappe-bench/env/local/lib/python2.7/site-packages/click/core.py”, line 956, in invoke
return ctx.invoke(self.callback, **ctx.params)
File “/opt/erpnext/frappe-bench/env/local/lib/python2.7/site-packages/click/core.py”, line 555, in invoke
return callback(*args, **kwargs)
File “/opt/erpnext/frappe-bench/apps/frappe/frappe/commands/site.py”, line 33, in new_site
db_type = db_type)
File “/opt/erpnext/frappe-bench/apps/frappe/frappe/commands/site.py”, line 66, in _new_site
source_sql=source_sql,force=force, reinstall=reinstall, db_type=db_type)
File “/opt/erpnext/frappe-bench/apps/frappe/frappe/installer.py”, line 36, in install_db
setup_database(force, source_sql, verbose)
File “/opt/erpnext/frappe-bench/apps/frappe/frappe/database/init.py”, line 16, in setup_database
return frappe.database.mariadb.setup_db.setup_database(force, source_sql, verbose)
File “/opt/erpnext/frappe-bench/apps/frappe/frappe/database/mariadb/setup_db.py”, line 13, in setup_database
if force or (db_name not in dbman.get_database_list()):
File “/opt/erpnext/frappe-bench/apps/frappe/frappe/database/db_manager.py”, line 58, in get_database_list
return [d[0] for d in self.db.sql(“SHOW DATABASES”)]
File “/opt/erpnext/frappe-bench/apps/frappe/frappe/database/database.py”, line 121, in sql
File “/opt/erpnext/frappe-bench/apps/frappe/frappe/database/database.py”, line 74, in connect
self._conn = self.get_connection()
File “/opt/erpnext/frappe-bench/apps/frappe/frappe/database/mariadb/database.py”, line 87, in get_connection
local_infile = frappe.conf.local_infile)
File “/opt/erpnext/frappe-bench/env/local/lib/python2.7/site-packages/pymysql/init.py”, line 94, in Connect
return Connection(*args, **kwargs)
File “/opt/erpnext/frappe-bench/env/local/lib/python2.7/site-packages/pymysql/connections.py”, line 325, in init
File “/opt/erpnext/frappe-bench/env/local/lib/python2.7/site-packages/pymysql/connections.py”, line 630, in connect
raise exc
pymysql.err.OperationalError: (2003, “Can’t connect to MySQL server on u’localhost’ ([Errno 111] Connection refused)”)

check if your mysql service is running or not

systemctl status mysql

@Crikey After a lot of frustration I think I’ve figured this out. Incredibly, one must manually add HTTPS ports to the security group:

HTTPS    TCP    443
HTTPS    TCP    443    ::/0
1 Like

If you SSH into your droplet instead of using the Digital Ocean terminal, you can copy and paste the initial root password.

Totally agree about the difference in easy install on AWS vs Digital ocean part.
I too spent 3 days in resolving multiple errors while attempting installation on AWS instance. After reading comments from @Crikey, I decided to try out installing on Digital ocean. It was so easy! Followed the easy steps and ERPNext was up and running in 15 minutes.
On side note, I still am attempting to resolve multiple errors on AWS instance.

Is it good idea to ssh using root on AWS instead of “ubuntu” user, which any ways has sudo rights?

It is always advisable never to use root user to install ERPNext because of permission issues down the line. I have an instance running on AWS and it wasn’t much hassle getting it to run with the ubuntu user but i also created a user which i used for the installation and so everytime i login using the ubuntu user i switch to the created user before running any commands.

Thanks @flexy2ky for your response. I had requested answer from @gavindsouza, as I believe he had suggested root user to install ERPNext in another thread.

Coming back to my question. I continue to face the issues with AWS. Ubuntu console shows that ERPNext was installed successfully. But, first page i.e. login is distorted. In chrome dev tools error shows below error
Failed to load resource:
GET http://myip/assets/css/frappe-web-b4.css net::ERR_ABORTED 404 (Not Found)
Same error for frappe-web.min.js.

Request the community for help!

@Crikey and all,

Finally issue was resolved for me by referring this thread:

Solution suggested by @sagar worked for me:
Try the following command:
bench build ,
bench migrate && bench clear-cache