Web Form v12 (Field Link not permitted)

Hi all,
I have a web form called create-user.
In that web form i have field called “Entitas”, basically it’s group.
This field “Entitas” link to Entitas Doctype.
But when i fill the web form and i fill “Entitas” field . Error show “Not Permitted”. ( image below)

I did set “Entitas Doctype Permssion” for guest to read, write, create, delete.
Question: any leads to this pop up message?


Thanks for reporting this issue! Was able to replicate this, I have created a Github issue here

Thank you for your response @jaichavan

Also i think there’s bug according web form field, for example Mandatory Field not highlighted, Field not hidden/read only, and custom script is not working. ( I attach some photo below)
Question: Is this also a bug? Please let me know if you can replicate this. Thanks a lot :grin:

I set “Nama Depan” Field to Read Only and this happend

I set “Email” Field to Mandatory

In custom script, web-form - js but the value still empty
(also tried another field = result same) and i try my best following this guide still no luck : Customizing Web Forms

Hi, i’m still facing this issue on v13. Guest role added to view in the Role Permission Manager.
Also added in the Doctype role table directly.

Both not working .

Any experience user on the web form to enlighten me ?. Thanks