Weird Error on ERP

Since this morning, I’ve been facing a weird error

The application has been updated to a new version, please refresh this page

I’ve tried clearing my cache, restarting the bench, and restarting the server. But nothing has helped. Has anyone else faced this issue?

Any help on this?


I just noticed, I also have a problem with bench update. This is the traceback:

    sudo: sorry, you must have a tty to run sudo
Traceback (most recent call last):
  File "/usr/bin/bench", line 9, in <module>
    load_entry_point('bench==0.92', 'console_scripts', 'bench')()
  File "/home/frappe/bench-repo/bench/", line 60, in cli
  File "/usr/lib64/python2.7/site-packages/click/", line 700, in __call__
    return self.main(*args, **kwargs)
  File "/usr/lib64/python2.7/site-packages/click/", line 680, in main
    rv = self.invoke(ctx)
  File "/usr/lib64/python2.7/site-packages/click/", line 1027, in invoke
    return _process_result(sub_ctx.command.invoke(sub_ctx))
  File "/usr/lib64/python2.7/site-packages/click/", line 873, in invoke
    return ctx.invoke(self.callback, **ctx.params)
  File "/usr/lib64/python2.7/site-packages/click/", line 508, in invoke
    return callback(*args, **kwargs)
  File "/home/frappe/bench-repo/bench/", line 241, in _update
    update(pull, patch, build, bench, auto, restart_supervisor, requirements, no_backup, upgrade, force=force)
  File "/home/frappe/bench-repo/bench/", line 276, in update
  File "/home/frappe/bench-repo/bench/", line 306, in restart_supervisor_processes
    exec_cmd(cmd, cwd=bench)
  File "/home/frappe/bench-repo/bench/", line 105, in exec_cmd
    raise CommandFailedError(cmd)
bench.utils.CommandFailedError: sudo supervisorctl restart frappe:

this is the error.
Try to run sudo supervisorctl restart all and post output here


[root@localhost home]# sudo supervisorctl restart all
frappe:frappe-worker: stopped
frappe:frappe-web: stopped
frappe:frappe-workerbeat: stopped
redis-async-broker: stopped
node-socketio: stopped
redis-cache: stopped
frappe:frappe-worker: started
frappe:frappe-web: started
frappe:frappe-workerbeat: started
redis-async-broker: started
node-socketio: started
redis-cache: started
1 Like

Looks like all ok


Thanks for pointing me in the right direction. Fixed it by changing the following in /etc/sudoers:

Defaults requiretty to Defaults:{username} !requiretty

1 Like