What is the purpose of the Set User Permissions option in the Role Permissions Manager?

Hi ,

I assumed the ‘Set User Permissions’ option via the Role Permissions Manager was to enable creation of User Permission documents for the relevant doctype… This however doesn’t seem to have any effect in that regard. So what exactly is this setting for?

Kind regards,


Yes, you are right. The button for User Permission is just to navigate to the list view of user permissions, and this is intentional.

Hope this helps.

Hi @michelle

Thanks for your response. For the avoidance of doubt, I’m posting a screenshot below:

If we’re referring to the same checkbox then I think the option is wrongly named and is therefore misleading. It should be renamed to ‘View User Permissions’ instead


Hi @wale,

Apologies, I was referring to the “Set User Permissions” button at the top of the Role Permissions Manager. The checkbox means that that particular role can update User Permissions for a user for that doctype. Does that not work as expected?

1 Like

Exactly what I thought… It doesn’t work :pensive:

Hmm, yes. I checked. It does not work as expected. In fact, only the system manager can give/delete permissions. User Permission is not accessible to other roles anyway. Thanks for reporting. We will get this fixed.


Thanks a lot @michelle

I have also noticed that trying to achieve this manually by giving a Role the permission to create User Permission documents is actually possible. The problem however is that you can’t limit them to particular Doctypes. So for example, I could give HR Manager role the right to create User Permission but trying to limit him/her to create only for the Employee Doctype doesn’t seem to work

I tried creating a User Permission that limits the HR Manager user to only Employee Doctype in the User Permission document but it doesn’t work. I’ve explained the Issue below:


This whole approach will however be unnecessary once you get the feature fixed in the Role Permission Manager


Hi @michelle

Happy New Year! Any progress on this fix pls?

Kind Regards,

Hi @wale,

Happy New Year :slight_smile:
Currently, we haven’t taken this up yet. I will update here as soon as it’s fixed.

1 Like

Thanks @michelle