What permission setting did i miss?


i did a custom report that i would like some user to view

Following the tutorial at frappe academy for user, roles and permission, i’ve add the role for the specific report on the “permission for page and report” doctype
then i make a shortcut for the report on the workspace.

now the user assigned that specific roles can see that they have access to the report but when they click it, a message saying that they have no access to the report pop up

anything i miss?


I guess, maybe you need check too if this role has permission to the doctypes used in the report on the Rol Permissions Manager by read and report.

Hi Malvin, thanks for the reply.

the report is based on stock ledger entry
i tried giving the role permission of:

  • stock ledger entry - read and report
  • report - read and report
  • prepared report - read and report

the report is not standard and

still “you don’t have access to Report: [report name]”


i think its not permission to read and report the doctype report and prepared report, rather, permission to “view report”

anything comes to mind anyone?


by default report link brings the user to design other than run report page, because the user is not authorized to design(Edit) report, so permission error popup, the solution is to check Is Query Report in link detail popup window in work space form like below

Dear Szufisher

i did as you told and still the same result.

i tried to assign the user standard role of
-prepared report user
-report manager

still cannot bear the wanted result. as far as i’m know, only when i assign the standard role of system admininstrator will the report work with the user

please provide screenshot of report Item Movement definition form view.

this one?

JSON result of editing a standard report and saving it as new report

{“columns”:[{“label”:“Item”,“fieldname”:“item_code”,“fieldtype”:“Link”,“options”:“Item”,“width”:100,“id”:“item_code”,“name”:“Item”,“editable”:false,“compareValue”:null},{“label”:“Item Name”,“fieldname”:“item_name”,“width”:150,“id”:“item_name”,“name”:“Item Name”,“editable”:false,“compareValue”:null},{“label”:“Warehouse”,“fieldname”:“warehouse”,“fieldtype”:“Link”,“options”:“Warehouse”,“width”:100,“id”:“warehouse”,“name”:“Warehouse”,“editable”:false,“compareValue”:null},{“label”:“Stock UOM”,“fieldname”:“stock_uom”,“fieldtype”:“Link”,“options”:“UOM”,“width”:90,“id”:“stock_uom”,“name”:“Stock UOM”,“editable”:false,“compareValue”:null},{“label”:“Balance Qty”,“fieldname”:“bal_qty”,“fieldtype”:“Float”,“width”:100,“convertible”:“qty”,“id”:“bal_qty”,“name”:“Balance Qty”,“editable”:false,“compareValue”:null},{“label”:“Balance Value”,“fieldname”:“bal_val”,“fieldtype”:“Currency”,“width”:100,“options”:“currency”,“id”:“bal_val”,“name”:“Balance Value”,“editable”:false,“compareValue”:null},{“label”:“Opening Qty”,“fieldname”:“opening_qty”,“fieldtype”:“Float”,“width”:100,“convertible”:“qty”,“id”:“opening_qty”,“name”:“Opening Qty”,“editable”:false,“compareValue”:null},{“label”:“In Qty”,“fieldname”:“in_qty”,“fieldtype”:“Float”,“width”:80,“convertible”:“qty”,“id”:“in_qty”,“name”:“In Qty”,“editable”:false,“compareValue”:null},{“label”:“Out Qty”,“fieldname”:“out_qty”,“fieldtype”:“Float”,“width”:80,“convertible”:“qty”,“id”:“out_qty”,“name”:“Out Qty”,“editable”:false,“compareValue”:null}]}

this is the resulting report

i tried to provide access to report list doctype, it seems the role don’t have access to acny of the report


please make sure the user also has been assigned role for (reference) report Stock Balance.

Dear Szufisher

That solved the issue, thank you very much for the help
i get it now, i need to give permission for the report that its based off on as well

thank you again