When doing a bench start, App is not working


I just faced this issue today. When doing a “bench start”

got below error.

Please help…

Hello @hetal1110,

Are you on development or production mode?
Did you take the latest updates of erpnext or frappe?

Follow the below commands:

sudo supervisorctl stop all
bench update --requirements
bench build
bench migrate
bench clear-cache

I hope it will be helpful to you.

on development mode.

Try This command
echo fs.inotify.max_user_watches=524288 | sudo tee -a /etc/sysctl.conf && sudo sysctl -p

Follow the commands:

Tried but still get the below error, from today…

While doing bench update --requirements,

Please install these dependencies using the command:

while applying given command, also got an error

sudo apt-get install -y libtiff5-dev libjpeg8-dev zlib1g-dev libfreetype6-dev liblcms2-dev libwebp-dev tcl8.6-dev tk8.6-dev python-tk

bench build

what to do next?

Do you have any custom app or only the erpnext base application?

Some package or required lib. is not installed properly.
Take the latest update of the ERPNext and Frappe and re-follow above mentioned commands.

Is your setup on Windows Ubuntu subsystem or Virtual Machine?

Virtual Machine.

Seems to be a problem with some node package. Try running yarn from frappe-bench/apps/frappe folder and then do bench start from frappe-bench folder

Only custom app… I have not make any changes in erpnext .
we are just exploring erpnext from last month, and today we have a demo to our team.

But when doing bench start, suddenly I got an error…

I haven’t take any update. we are using VM and using frappe by importing dev.ova. Making changes in code by doing sftp:download

So I don’t think bench update is the solution.


I was also thinking the same, but no luck

Its already updated

What is your node version?


Node should be atleast version 6

sorry…its v6.14.1

I have given you npm version.