Why can't I hide the "Scan Barcode" field in Stock Entry?!?

I have implemented v13 ERPNext in a location that does distributions to multiple warehouses. They had previously used ERPNext v10 and were familiar with how to build Material Transfers using custom programmed barcode scanners.

Now with v13 there is a new field called “Scan Barcode” that allows you to build a Material Transfer table in similar way to how a POS checkout scanner would work. You park the cursor in the “Scan Barcode” field and then just start scanning your stuff and it auto-populates the “Items” table.
See screenshot below:

The problem I have is the old scanner programming does not work properly with v13 so I need to reprogram all of my scanners.

In order to prevent the continuous flood of help desk calls, I need to temporarily hide the “Scan Barcode” field from the users view.

I logged in as Administrator and went to the “DocType” for Stock Entry:

If you notice from this screenshot, I am in fact logged in as Administrator and all of the editable fields are greyed out. See the check marks circled in red? That means that even the Administrator cannot edit the Stock Entry from the Customize screen to hide fields or change anything.

No matter what I try or what login I use, I cannot seem to check the hide setting in DocType for the Scan Barcode field.

Am I missing something?

Is there some alternate way to do this?

It will take a few weeks for me to arrange for the barcode scanner company to mass update all of my scanners in this 400 mile radius territory to allow them to work properly with this feature.

For the current time, the scanners can still work by setting the cursor in the first barcode field in the first row of the table and progressively building the transfer table just like they did in the old v10 system. So, for now I really want to hide the Scan Barcode field and I am clueless on how to get into it to actually check the hide boxes.

Any clues here would be greatly appreciated.

BKM :nerd_face:

In Inventory Settings have a check for that.

No… not good.

While the setting you describe does remove the “Scan Barcode” field, it ALSO removes the Barcode field column from the Items table. Not good.

This is NOT what we need. We still need the Barcode column in the table because many Items are not labeled with Item Codes. They only have manufacturers barcodes on them and cannot be scanned into the table if there is no Barcode column.

I need to ONLY hide the “Scan Barcode” field in this section, but even as Administrator, it is greyed out and I cannot find a way to check the “hide” setting.


Hey @bkm,

You can create a client script for Stock Entry, on the refresh event toggle the field to be hidden.

If you want to edit the doctype, you’ll need to have developer_mode on. That said, is there a reason you prefer to edit the doctype instead of using the customize form tool? From there, I was able to hide the Scan Barcode field like normal on my dev site. YMMV, though.

1 Like

I am a little surprised you tried to do customization via directly changing DocType instead of Customize Form.

Anyway, I learnt a lot from your professional posts so far. hopefully we can help you on some minor issues in return.

1 Like

This is embarrassing… :confounded:

I want to thank @peterg @szufisher both of you gentlemen for being so kind in your reply.

In my own stressful times of trying to put out all of the fires related to starting out on a fresh and new production environment, I got myself flustered and checked the wrong box in “Customize Form”

I checked this location in my incorrect attempt to hide the field:


When this did NOT work for me I assumed there was something else wrong in the system and started going directly into the DocType.

After the two of you were so kind as to nudge me back into a better state of mind, I re-examined my work in “Customize Form” for Stock Entry and found my mistake. I was supposed to check the box in the below screenshot instead:

You have both been very kind.

Thank you for the mental assistance. I should know better.


BKM :upside_down_face:

1 Like

I think this happened to many of us, even the old timer :smiley:
Usually I come back to this forum and reread everything… before I got my aha! moment.

1 Like