Wizard freezes on stage 4


Im trying to figure out why the wizard would freeze on the last stage. What I noticed is that if I choose country ‘South Africa’ then it freezes. When I stop browser I get the wizard screen but the chart of accounts is blank. Something does not look right with getting the chart of accounts for South Africa.

If I choose a different country - lets say United Kingdom then wizard works not problem.

Can someone please help me trouble shoot this issue. I have a work around in that I change the country to UK and then when I get to desk I just go to settings and change to South Africa.

Kind regards

I’ve had problems with the wizard too. Are you running in production mode? Do you have at least 2gb of ram? At one point in time, I remember I got around the problem by repeatedly trying in Firefox and Chrome until it finally worked.

Hi Hemant,

I too experienced the identical problem with the South African country setup and resorted to your work around.

What is strange is that I have done several setups for South African entities and not come across this issue before. I have not updated my system recently and therefore cannot figure out the sudden cause .

This happened to me last night. Wizard froze on stage 4. I was configuring USA - Los Angeles.

It’s not the 1st time I’ve seen this. Happened also maybe 12-14 months ago.

I actually don’t know how I got past it last night. It was 3am, and I was tired and frustrated. But here’s what I did:

  1. Created a brand new site, and added ERPNext as an app.
  2. Stepped through the wizard. Anytime there was a field? I clicked it. Even if it was filled already.
  3. I’ve previously had problems with Fiscal Start and End dates. So I deliberately clicked into each date. Chose it from scratch. Even though it was already January 1st and December 31st.

And it worked that time.

I have no proof. But sometimes I “suspect” that values are cached/shown on the screen. But aren’t actually submitted when you finish the wizard. And so the wizard fails, because of missing data.

Again, just a theory. The message when the wizard fails is meaningless. And bench shows nothing.

1 Like

Hi Brian,

Odd coincidence that it was also 3am when I ran into this issue!Perhaps it only happens at that hour :wink:

Thanks for sharing . I’ll try out your suggestion at the same hour again and will advise.

1 Like

Good Day

Also had same problem, but mine could be VPS Ram only 1Gig, but will check when they move my ram up to 4Gb.

I have tried completing all the data in the forms as advised, but still no success.

I honestly don’t know what could be causing this issue.

@Albertus, I don’t think it’s related to Ram. My laptop has 16Gig total, about 11.5 free and available.

Will have to debug/step through the code, to figure this out. :confused:

Before using the setup wizard try to clear the browser cache. And try selecting and entering values even in the default loaded fields, especially the mandatory ones.

Good Day

Did anyone get solution for this?
If i do setup selecting South Africa then browser freeze, but when i select United States as a test then it works.
Could someone shed light why if South Africa selected the browser will freeze?

Thank You

Albertus Geyser

Hi @Albertus,

I don’t have a solution. I did what you did, pick a country, like UK, then once the setup is competed I go backup to company and change it back to south africa.

I tried to figure out what’s going on in the code but still struggling with that. I suspect the chart of accounts for south africa is empty.

Maybe there is a github issue regarding this, if not maybe we can log one.

Kind regards

I’ve run into the same thing on numerous setup attempts. The only solution I’ve ever found is to just keep trying over and over again. Eventually, it has always worked for me.

Given the erratic nature of the bug, I suspect there’s some kind of race condition going on. I’ve spent a few hours trying to go through the setup scripts to see if I can spot a problem, but it’s a tough nut to crack. There aren’t many people familiar enough with the code base to understand what might be causing the problem.

I agree with @peterg. The only solution we have (for now), is to try multiple times. Until it works.

There are many similar issues already on GitHub. No point opening a new one.

This issue needs some development work to resolve. I want to spend time on this. But it will be a few weeks before I can examine the code. First I have 2 Bench issues I need to complete. And then I need to solve an IMAP/SMTP issue with ERPNext, so that it works with all email hosts. Installation Wizard is Task #4 on my “wish list.”

If another developer can fix first, then fantastic. But this has been an open bug for a very long time. So I’m not very hopeful.

In the meantime, just keep trying until it works. I know that’s a terrible answer. But it’s all we have right now.

1 Like

I have had some degree of luck reducing the number of tries by alternating between Chrome and Firefox until brute force gave me a successful install.

It might be nice to shut the wizard off completely for advanced users.

My luck… Not 5 minutes after posting this exact same problem, I found this topic.

I’m from SA< did the same, got stuck at Wizard 5 - just hangs, and when I reset the page it goes back to Step 1.

I get around it by making a USA company, then a new SA company and then deleting and de-linking all from the USA company, but it’s a real hassle.

I’ve also seen the default S.A. VAT is still at 14% and asked for that to be updated to 15%.

Anyway, if anyone figures out the real deal here, PLEASE post it, this is an annoying problem. I’m going to try the “click every box” approach next.


please try from bench terminal

bench config http_timeout 6000

or add time out to 6000 in common_site_config “http_timeout”:6000,

most probably the the wizard freezes on setting things up. if you increase timeout it may work.

Thank you

Thank you for the suggestion.
Is there a way to query my current bench http_timeout?

(You know, in case it works so I can script this and have it always…)


The default timeout of ERPNext is 300 seconds (as I believe). If the entry is not in common_site_config then it’s taking the default settings. We are overwriting that by our entry…

@M27 and @Cuz

Tried to increase the timeout - still hangs after click next on “Brand” step.

The timeout is not the thing. Also, it hangs immediately by step 5, not after a time of thinking.

Also, this is easily reproducible, I have so far been getting it the exact same with Dev branch, with Master branch, and even with the ERP pre-made demo (the downloadable disk image).

Surely any dev can easily reproduce this and (I’m hoping!) fix the bug in stead of suggesting more and more weird solutions.

To reproduce:
Spin up ANY version of ERPNext on an blank install…

IN the Wizard, pick the default English, then for Country “South Africa” and see it selects Timezone as Africa-Johannesburg and Currency as ZAR (South African Rand) correctly.

Progress the Wizard further in the normal way. It won’t get past step 5.

I’m thinking It’s the “South Africa” setup script that’s broken, but I could be wrong. I am however sure it is reproducible.

Please help on this - there’s a whole Country that feels neglected and it especially hampers me demoing it to companies (I have to now do the workaround before-hand).

PS: To my S.A. users: For now I found the best workaround is to pick Botswana (they also have VAT) as the Country, but overwrite the default Currency and Timezone to Rand (ZAR) and Africa-Jhb, then later just change the Country for both the Company and the System Setup and change the VAT to 15%.