WKHTMLTOPDF not loading local css

Hi ,

The wkhtmltopdf is not printing the local css , tried everything listed here but I am not able to find a solution.
In spite of developing the print format due to this issue I am not able to use it , could anyone help me ?


How do I make wkhtmltopdf and the default html print to print the css ? Even I tried embedding directly using the <style> tags , the direct print option and pdf as well , is not loading the css and I could not see anything in the print preview .


The html preview I get

But the print preview and pdf are just black and white. I embedded the font color directly , I did not use a css here but I am not getting the blue colored font . Please help

What should I change in this to make it load my local css in the custom print I developed

<base href="localhost:8000">
<link href="/assets/css/style.css" rel="stylesheet">

Any help please ?

bump bump :innocent:

You need to set the global path for wkhtmlttopdf

1 Like

Thanks for reply , could you please tell me how to do that ? Thanks

@Muthu Please note that, it is expected you to perform google search before asking questions here on forum.
Follow this: ruby on rails - WKHTMLTOPDF path in ROR application - Stack Overflow

This topic was automatically closed after 3 days. New replies are no longer allowed.