Wrong or difficult Tax Selection

Hey folks,
I have two articles, one has a 19% tax, the other has a 7% tax.
In the article list, I entered these taxes for each.
When I create an invoice with both of these articles, the taxes aren’t split to each position.

Article 1 - 19% 100€ netto
Article 2 - 7% 100€ netto

Now I can create invoices that don’t calculate taxes at all, or if i enter them manually in the form I get the same taxes for both articles. (238€ or 214€) , but it should be 226€.

How do I get the pre-entered taxes for the articles automatically?

Thanks for your help.

You can try with “Item wise” Tax.
In Item master you can give separate Tax

You can check https://frappe.github.io/erpnext/user/manual/en/accounts/item-wise-tax.html

Hi shraddha,

thanks for your reply. As I described above, I already did that . Please take a look at the screenshots.

As you can see, on “Artikel 3” I entered a reduced tax of 7%, but in the invoice, 19% is chosen.

If I add the 7% tax type in the invoice, both tax types are added to both items.

check with "Account head " in sales invoice for that item and “Tax” in Item master type
Example :- Article1 is my item
in that i select Tax=Administrative Expense-A with rate=7
and save item form.

Now, In sales Invoice
ON Net Total ,Account Head=Administrative Expense-A and Rate=0 (zero)
Now you can break-up and see.

Hi shradda,

I’m not sure, if you understand me correctly.
The tax in ‘Sales Invoice’ is not the one, I selected for the item, but the default tax.
I unchecked the default-box for 19% now, but now no tax is calculated for the items.
I just want, that Article 2 is charged with 19% tax, and Article 3 with 7% tax in the same invoice.

When you select another type /Account Head in sales invoice with rate=19 then off course it taking same rate for both item .Because you defining different type of tax in Item master and and different type in sales invoice.
-In Item Master,
1.Item=Article 2- Tax=Administrative Expense-A Rate=19
2. Item=Article 3- Tax=Administrative Expense-A Rate=7

Save both form.

In sales Invoice, select Both Item
Inside Tax table grid,
On Net Total , Account head should be same as Tax type define in Item master(i.e Administrative Expense-A) for both item and Rate =0
save Invoice form.
and then check.

i am not understand from where you “unchecked the default-box for 19%”

Ahhh, I’m sorry shradda… You understood me perfectly, but I didn’t understand you in the first place.
I see my mistake clearly now and it works!

Thank you!!

It’s Okay :slight_smile: