Yarn build - Api not working , existing api and old code is working. For new api's its not working

Hi sir,
@buildwithhussain @nikkothari22

I have two instance now. I want to move my exisiting app into new instance.
Existing Instance:
Frappe Framework: v15.0.0-dev (main)
bench version: 5.22.3
node --version 16.0.0

New Instance:
Frappe Framework: v15.x.x-develop () (develop)
bench version: 5.22.3
node --version 18.20.2

In new instance i created same site name and clone that app from gitlab. in app’s folder
App Name : turiya_app

Now i run the command

  • bench new-app turiya_app

This app already has react setup and code.

Inside folder
React Folder: turiya
I run yarn install and yarn build.

After that if we refresh any react page means it expects that page in frappe webpage.
In this approach 8080 new api is working. After yarn build it’s not working

Approach 2:
I tried another approach. i created New App: turiya_app.
and created new react setup named turiya. I moved doctype from existing app to this app and react code also and i run yarn build means. Existing api and code are working. Newly creating api are not working. I am getting issue. For new api only issue it returns index.html file in response.

In this approach 8080 and yarn build also new api not working

How to approach this in my scenario.

Thankyou sir