You can't set 'Options' for field Company


I am having the strangest error with my Customize Form Script.

The Company field is NOT SHOWING on the Material Request form. I have made sure the Hidden attribute is not selected.

I have created a duplicate Company field with the exact same values, and that is working fine.

It’s almost like there is a problem with the Company field and the data is now locked up.

When I attempt to delete it so that I can re-add it, I receive the error message “Cannot delete standard field. You can hide it if you want”

Here are the settings inside of the Company attribute:

When I attempt to remove the Option for Company, I receive this message “You can’t set ‘Options’ for field Company”

What is wrong? Can you please help?

(screen shot of the Material Request form with the Company Field missing)

(Screen shot of the Company 2 field that is an exact replicate of the Company field (the one that is not showing on the form).

Hi @spayne22,

I can reproduce your observation. It also affects other DocTypes such as Sales Order and so on. The leads me to think that this field is used internally to make sure a record is assigned to a company and uses the corresponding access rights. It is set on creation by the code and cannot be changed.

If you want to make it visible, this worked for me: I have added a field “display company”, which reads the company (Options: and makes it visible (row 11):

It only works on new records though…

Thank you for the work around @lasalesi!! I will remember this and try it if I run into this problem again. Thank you!!