Add New Party Type

How i can add new party type

1 Like

I tried to create a new party type but in my instance, there is no option to create a new party type, can you please give more details about your requirement and use case. I even tried to add permission in setup>DocType - Party Type but it is not allowing with massage - {Not in Developer Mode! Set in site_config.json or make ‘Custom’ DocType}.


I am having the same issue. I want to create a new Party but cannot do so. I have logged in as administrator but there is no “NEW” button when I check the Party Type List.
Can anyone please help.
It is urgent.
I am using ERPNext: v10.1.72 (master)


Possibly a user role and permission setting prevents this so play with those?

But I read even as Adminstrator permission settings can be elusive!?

Keep us informed how it goes and what you find.

Thanks for the reply. I have checked all the roles of administrator. But still cannot find the button.
Can you please advice if there is something must be missing ?


ok I can confirm your same issue on these versions too

ERPNext: v10.1.20 (master)

v11.0.3-beta.2 (a7ae06e) (staging)

My guess is this relates to sbkolate kolate_sambhaji 's report in June Addresses And Contacts - party type lead is missing · Issue #14896 · frappe/erpnext · GitHub
umair or Jai_Chavan may have some ideas here.

Party Type comprises a list of child tables.

A workaround may be to run in developer_mode?

Im a networking guy, not a developer, so please bear with me.
And help me resolve this issue. I have tried to go in the developer mode but then the server says INTERNAL SERVER ERROR.

Please advice.

I suggest you consider paid support?

Is this resolved in the previous versions - or in the newer version ?

its not in production mode. I am testing it at the moment.

Excellent the idea is to contribute :wink:

Open Role Permissions Manager

Select Doctype - Party Type

Since you are already logged in as Administrator and still can’t see the New button it seems some role is lacking the Create permission.

If there is System Manager then provide it the permission to Create or else Just create a new rule and give the System Manager permissions on permlevel 0 - it contains the permission to Create

Thank you for the reply. That is what I also thought.
I tried your method earlier, these are not applicable - unfortunately.

I cannot select write nor can I add another role. Cannot give role a name so it doesnt save.

Any ideas?
I have made a fresh install (I have downloaded the VM from the site)


Log in as Administrator

I am logged in as Administrator. :frowning:

Hey I see you are editing permissions directly in the DocType’s form. Don’t do that.

Instead open Role Permissions Manager.

Select Party Type in the DocType list and then change permissions or allot new permissions to a different role. These changes will stay in database and will not lead to edits to the JSON file in the erpnext code.

1 Like

thanks for your tip Jatin

I linked this thread to here Addresses And Contacts - party type lead is missing · Issue #14896 · frappe/erpnext · GitHub

1 Like

Many thanks for your reply.

I was still not able to add a new party type via that way, however, I added by directly adding an entry to the DB table.

Please check the below image.

The reason for this was that I wanted to make a party which will be a supplier as well as customer so that I can make sales and purchase from it - having a joint ledger.
Please guide me that from where can I now start adding party names against it.
Im confused. :frowning:

Please help. please !!

And yes I have checked the post “clarkej” has made, the “VENDOR” (party type i added) is not showing in contact list.

Hello Again,

I have manually fresh installed and I still cannot see the New button in the party type list.
Anyhow please check the following error, it arises when I try to import the data via the data import list.
And I installed from the following link:

Traceback (most recent call last):
  File "/opt/bench/erpnext/apps/frappe/frappe/", line 60, in application
    response = frappe.api.handle()
  File "/opt/bench/erpnext/apps/frappe/frappe/", line 39, in handle
  File "/opt/bench/erpnext/apps/frappe/frappe/", line 134, in validate_oauth
    from frappe.oauth import get_url_delimiter
  File "/opt/bench/erpnext/apps/frappe/frappe/", line 8, in 
    from oauthlib.oauth2.rfc6749.grant_types import AuthorizationCodeGrant, ImplicitGrant, ResourceOwnerPasswordCredentialsGrant, ClientCredentialsGrant,  RefreshTokenGrant, OpenIDConnectAuthCode
ImportError: cannot import name OpenIDConnectAuthCode

The version it had installed is as follows:
ERPNext: v12.x.x-develop () (develop)
Frappe Framework: v12.x.x-develop () (develop)