Add New Party Type

Navigate to the Role Permissions Manager. You’ll see that no one has permissions to create a new party type by default. I suspect this is not a bug.

I added the ability to create Party Types to System Administrator and the started a new Party Type:

There isn’t a built in way to make it both payable and receivable. And when I tried to create a receivable and payable record for one doctype, there was a validation error. I don’t know the story behind this but it does seem like there should be some facility to have a party be able to both be pay and receive, it may be custom. I know @saifi0102 knows about this because he worked on it in his Letters of Credit PR.

I have the same issue, however, I tried @tmatteson solution and it works,

The problem I got, when I delete the student as a party, still appears on the party list

how can I delete it permanently?

thank you.

From what I know. It’s not possible to set a party type as both Receivable and Payable without major changes to the system. A lot of ERPNext functionality depends on the fact that a party type is either Payable or Receivable

1 Like

Thanks for your reply Saifi0102

But we have some parties who are our suppliers as well as our customers. Can you advice anything regarding that ? That is the reason we are trying to add another party type so that we can make transactions to (sale/purchase) to them.
Please advice.

Yes, make a Customer and a Supplier for the same person/company. You can adjust their balances using Journal Entry.

Yes, that is what we thought. But we want to have a single account for that party. That will be easy to manage as well as remove another step of journal entry.

1 Like

Hi Kanuna,

Did you get the solution for

from oauthlib.oauth2.rfc6749.grant_types import AuthorizationCodeGrant, ImplicitGrant, ResourceOwnerPasswordCredentialsGrant, ClientCredentialsGrant, RefreshTokenGrant, OpenIDConnectAuthCode
ImportError: cannot import name OpenIDConnectAuthCode

Please guide me,

You gave the solution to this error in that post.
Just for other people’s reference

1 Like

@kanuns I agree that this is the goal, but as @saifi0102 mentions, it’s going to take some work to get there. I’m going get it on the agenda for the accounts working group, but it seems likely that this will need to be a sponsored effort.

I have an idea to link Customer and Supplier together and easily balance their accounts. I will post something once I develop that idea.

1 Like

Maybe this thread can relate to my thread here: [Not an issue] Wrong link for creating new Party Type.

In my post it is marked as Not an issue. And it is left as it is (nobody responded to it).
So I assume Party Type list is intentionally connected to new DocType creation.

But I still don’t understand why…?!?

If one has the permission to create a party type. they can create a new party type but not from the list. You just do the following:


I am also having the same issue. It seems to be a bug. I am not able to create any new Party Type. I am logged in as Administrator.

When I open the Roles Permission Manager and navigate to the Party Type, I don’t see any create permission. See image please.

Any clues?

This method is not workable. The new entry form is not complete. Therefore, the save button returns an error.

You need to untick “user cannot create” option on Doctype of Party Type

1 Like

Thank you for your relpy, @Aadhil_P_M

When untick this option and click save, I got this message:

Not in Developer Mode! Set in site_config.json or make ‘Custom’ DocType.

You need to enable developer mode:
Option 1 :
frappe-bench folder, run following command

bench set-config developer_mode 1

Option 2:
Update the site_config.json file of your site in the sites folder:

frappe-bench/sites/{your site}/site_config.json

Add following line of code on site_config.json file.
“developer_mode”: 1,

1 Like

Thank you so much, Aadhil. I got it. :green_heart:


I am trying to pass the key:value pair as suggested in the frappe cloud site’s configuration.

However I am receiving the following error:

Would appreciate any help.


But isn’t that tampering with the Core functionality and not advised?