Admin password is not working

Hi, I have set up ERPNext on a Xenserver VM running Ubuntu 14.04. After the installation, I access the site through VM IP and get a screen like this.

At the email address: I put in Administrator and Password: the Administrator password generated by ERPnext. But it doesn’t work and I have verified the Administrator password a number of time.

I have tried various installations before on VMware ESXi 5.5. Whenever I got a login screen like this, I had similar problem of login. The only instance that I was able to login was a different welcome screen with only the top part of the form. Any idea?

Hi @jpstonepc,

Could you check the console log for errors?

I’ve a feeling you might be getting a 404 error for the CSS and JS files.

Yes. Error 404. What is the fix? What causes it? Thank you for your reply.

Had the same problem.

Try this: Installation fails due to mysql pass - #21 by Tanuj

Let me know if that helps!

All the best

chmod: cannot access ‘/home/frappe’: No such file or directory.

I also noticed ‘smb/cifs file and active directory server [fail]’ during reboot

Thanks for the help.

Fixed the ‘smb/cifs file and active directory server [fail]’ error

/home/frappe is the directory where I’ve installed Bench.
It would be different for you. In this case frappe is a user, and I’ve installed it in the root directory of frappe.

Your path would be /home/{username}

In case you haven’t installed it in the home directory of that user, replace the path with the directory you’ve installed it in.

All the best!

Have applied chmod 0+x and 0+r on /home/(username)/frappe-bench. Reboot. Now I can’t even get the login screen. Look at the nginx/error.log: all access failed (13:Permission denied). And I have reinstalled a clean copy of Ubuntu 14.04.03 and reinstalled the ERPNext by the easy setup instruction. I have spent two days on it…and now getting frustrated. I have looked all over for similar problems and solutions.

Your replies were, however, much appreciated.

@jpstonepc: Installation is a little frustrating, I admit, but it gives you an insight about the framework of the whole system.

Could you please tell me if you’re running a GUI on Ubuntu?

Well, looking at a glass half full… :slight_smile: Yes, I am getting to know the framework a bit more, but I also have a soft deadline. What I don’t understand is that it is supposed to be an easy setup with consistent and common environment. No I am running command line only on Ubuntu server.

Thanks again for the reply. Much appreciated!

@jpstonepc are you installing as root. Frappe is specifically designed to disallow that/

No. I installed it as User (first user created by Ubuntu server installation).


I think I have figured out what caused the problem. I have selected to encrypt the home directory during previous installation. I’ve tried without encrypting the home directory today and am now setting up the site without a hiccup. :slight_smile: