Backup restore error

We have installed virtualbox 5.0 & successfully installed ERPNext-250216.ova.

It will run on localhost:8080 with blank data base. But if we try to restore , it shows Internal Server Error.

We have followed below steps to restore backup file:

  1. Copy backup_sql_file into /frappe-bench directory
  2. enter command: bench --force restore database_file_name.sql

It shows no error in terminal, but in browser it shows Internal Server Error

Kindly suggest correct method to restore SQL file in detail.

Hi, can you download the latest VM and restore the backup?

Also run bench migrate after you restore. That should do it.

1 Like

@vjFaLk how to copy back file to /frappe-bench of vm as its ip address is

But our local system ip is

@vjFaLk how to copy backup file to /frappe-bench of vm as its ip address is

But our local system ip is

How did you copy it before?

You can change the VM Settings to change the network connection to Bridged, so it’ll connect directly to the network, and then transfer the file via File Share or FTP.

FTP Username and Password are frappe and the port is 22

@vjFaLk as we are using linux, copied sql file to /frappe-bench/ using scp command.

What will be the next steps?

  1. Do I need to create new site using “bench new-site site1.local”?
  2. Then to restore “bench --site site1.local --force restore file_name.sql” ?
  3. Then is there any commands?

@Ram_Gopal_Rao Try first without creating a new site

  1. bench --force restore file_name.sql
  2. bench migrate

@vjFaLk It Shows error: no module named frappe_subscription

Ah, do:

  1. bench remove-from-installed-apps frappe_subscription
  2. bench migrate

@vjFaLk still shows the same error

@Ram_Gopal_Rao i just had almost the same problem, but when i tried it with root user instead of frappe user it worked and restored already…

if you rely in your ERP on frappe_subscription then reinstall it then try as root user…

@ramielian what is root password?

@Ram_Gopal_Rao did you activate root user? if not then using your main user (the main user not frappe user) make:

sudo passwd root
then enter your password once
then enter root password twice…

@ramielian frappe_subscription is an app that is installed on our cloud servers. @Ram_Gopal_Rao has probably downloaded the backup from their cloud server. I’m unsure if running it as root would work.

@Ram_Gopal_Rao Try this then

bench --site erpnext.vm --force restore file_name.sql
bench --site erpnext.vm remove-from-installed-apps frappe_subscription
bench --site erpnext.vm migrate


To restore i used “bench --force --site ramgopal restore file_name.sql”
It asked Mysql password & completed the process.

But when I used “bench --site ramgopal migrate” It Shows error: no module named frappe_subscription.

Did you make a new site ramgopal?

Did you do bench --site ramgopal remove-from-installed-apps frappe_subscription?

Now it shows eroor: no module named mandrill_integration

1 Like


i usd
bench --site ramgopal remove-from-installed-apps mandrill_integration
bench --site ramgopal remove-from-installed-apps knowledge_base

and completed “bench --site ramgopal migrate” successfully.

But how to open new site in browser? when I used http://localhost:8080 it dint accepted my user name & password…

kindly help

1 Like

Because you made a new site you gotta change some setting to make it work.

bench config dns_multitenant off
bench set-nginx-port ramgopal 80
bench setup nginx
sudo service nginx restart

You should see your website at http://localhost


it shows error while “bench set-nginx-port ramgopal 80”

“Port 80 is being used by another site ramgopal”