Bench init error on v12

I’ve been installing and using the v12 for quite a while and never have problems setting up.
Now I have errors when trying to do bench init.
It something to do with node-gyp I think. the package trying to look for python 2 (??).
When I try to bench init for v13 its ok, everything run smooth and no errors.

I am wondering why this is not happened before but now is.
I tried using version-12 and also version-12-hotfix. the error is the same.

my setup are on ubuntu 20.04, python 3.8 (default ubuntu 20.04), node 14 and mariadb 10.13
Anybody have the same problem and knows what happening ? (specialy about the node-gyp problem).



After hours looking and searching for solution from our community comments
and also based on the first error in the above problem which is
…/apps/frappe/node_modules/node-sass: Command failed.
Exit code: 1
I go to apps/frappe and do :
yarn upgrade node-sass
cd your frappe-bench directory
bench build

The problem solved.

continue to get-app erpnext, create site etc.

My simple conclusion is
node-sass version 4.13.1 somehow have problem in version-12 (??) because
after yarn upgrade node-sass which then install node-sass version 4.14.1 the problem gone.
I know it might be more reason for that but I leave that for the experts.

I also have pandas setup error when setting up and this link help me Bench installation of erpnext fails on pandas setup - #2 by satishvijayan


1 Like