Bench start ok, but dev website won't load, which ports to use?

Can you run bench serve --port 9000 and check if it is running on port 9000?
If not, then you need to check firewall setting.

no, see pic

Production setup or develop setup?

Are you facing same on chrome/firefox ??

dev setup
same on ff and chrome

firewall is not active

I did, port 8000 and 9000 were in use, and gave this error

port 8001 was free, i used it, but still no website visible on this port

these are the current processes, so ports 8000 and 8001 are used, but I cannot connect to them.

anyone an idea what could be wrong?

Maybe I am missing some files, and that is the reason I cannot access the website?
The install command was this:
$ python --develop --user frappe
This is the development setup.

I don;t see any apps or sites. Also there is no erpnext site I think?

Any ideas?

can you post output of bench --help

See if this makes a difference

sudo ufw enable

ok @kolate_sambhaji, here is the output of bench --help:

@clarkej: no difference with ufw enable

Ya!! Due to some reason it won’t create site.

bench get-app erpnext
bench new-site 
bench --site install-app erpnext
bench start

Then check localhost:8000

1 Like

Your connection timeout may be due to no network access -

Is on the public WAN side of your network gateway, so your router uses NAT to port forward 8000 to your erpnext box at within your LAN?

Test for port access to connect to http listener with these:

nc -v 8000
nc -v <some private ip> 8000
nc -v localhost 8000

These and other logs should offer clues


These are conventional LAN addresses - (65,536 IP addresses) - (1,048,576 IP addresses) - (16,777,216 IP addresses)

1 Like

Hi! Will it run on port 443 or 8443?

tx for the suggestion that it has to do with port access
microsoft azure vm did a ‘good’ job to block all ports, and obscure the vm port settings so you never find out … :disappointed:
I will check that now.

@saurabh6790, I think the missing sites have to do with this mysql error:

  1. I installed erpnext many times, and error keeps coming up.
    Maybe the install script should test if mysql is installed or not, and then do the appropriate commands, instead of just giving an error and continuing with the script.
    I think this is a bug in the install script.

  2. Also I am not sure what is installed in the dev and prod environments. Are the same things installed. Is erpnext installed in dev, or only in prod?

I tested the port settings of microsoft azure vps hosting.
It seems that azure by default closes all ports except port 22 fr ssh
Thus opening ports 80, 8000 etc. solved the ports issue.

I was not able to setup the dev environment because of the mysql error mentioned before.
Installing the prod environment went without errors, and I can access it.

@pee we will check develop script again and fixed it. Apologies for trouble.

Please share your system configurations, this helps us to reproduce the issue.

Thank you .

@saurabh6790 tx for your support.
what files or other info do you need from me?