Bench update is going bonkers


Is it just me or is there something funny going on with bench update. My environments are still on ver 11. When I run bench update I get the following error:

bench updateINFO:bench.utils:Updating bench
$ git pull
remote: Enumerating objects: 53, done.
remote: Counting objects: 100% (50/50), done.
remote: Compressing objects: 100% (14/14), done.
remote: Total 17 (delta 13), reused 4 (delta 3), pack-reused 0
Unpacking objects: 100% (17/17), done.
From GitHub - frappe/bench: CLI to manage Multi-tenant deployments for Frappe apps
6ecfa00…189d0c7 master → origin/master
Updating 6ecfa00…189d0c7
bench/ | 3 ±-
bench/ | 10 ++++±----
2 files changed, 6 insertions(+), 7 deletions(-)
INFO:bench.utils:Bench Updated!
Usage: bench update [OPTIONS]
Try “bench update --help” for help.

Error: no such option: --backup

However, if I run bench update --no-backup it goes through fine. Not just fine, it does the backups too.

Something’s fishy, right?



Hi Jay fyi Bench update fails due to no "bench --backup" option ?!?