Can not access to general ledger

I have set user permission to one company under user permissions, Then I have give access to user as account user who have access to company as read.

But when I try to see the general ledger reports no company showing

Any Idea?

@Sanath_Arachchcige Any updates regarding this???

You might need to set role permissions as well as user permissions

Actually, If you set default company under global setting, this will be OK.

This is my experience.

@trentmu @Sanath_Arachchcige Tried both but not make it :frowning_face:

try bench update, may be it fixed in latest version

When you open the report, just check the JS console if there’s any traceback. Post it here if there’s any, that’ll help us find the issue.

Hello ,
I am facing same issue ,is there any solution for this.??

I am facing the same issue also, please help me how to solve it!

To solve any problem first find out exactly what the problem is -

So to do that in the case here best to follow this request:

Note these too for permissions clues

Have you created the chart of accounts of the second company using first company? I had the similar issue. There are four companies. Only if I give access to the first company, other users will be seeing their company. When I give access to the first company, it is working perfect. But this is not correct. We are actually figuring out how we can solve the same?

Actually my problem is different.when user open the general report legder then there he can not able to select the company there .also i give the access of one company to that user but he will not able to access the company there.

Console error:-Uncaught (in promise) Filter missing
Uncaught Filter missing

Using this i resolve my issue

Go to system settings ==>permission disable the Apply Strict User Permissions check box it will work for me


FWIW here’s another permissions issue solved Company docType Access issue

Please post the full log, as that helps search and define a problem context, thanks


I resolve my issue