Cannot Complete ERP Next Setup [self install]

Dear Team,

I completed setup of Frappe. I was setting up Company Profile and details using Admin id and password, but it was stuck for long hours. Seems no hop

e. I have been here for weeks and so frustrated.

Could you please help. Screenshot Attached.

I thought this bug has been solved :frowning: from this url. ERPnext initial setup not complete? - #2 by gentle

@msuworld what deployment?

Did you do bench update and tried again?


Can you reproduce this on a free account

Yes, on Ubuntu 14.04, Dev Environment, Is there anything with below message :

As its stuck on the setup page for hours for long time.

I just set up online, its now running, but its not running locally on ubuntu 14.04. Can you please help.

Many thanks


I logged in locally with Admin id, now inputting the Admin information and its stuck there saying setting up. I spend hours here, several times done the steps, i am now stuck there.



tried bench update, no help.

I think Rushabh mehta and team missing something in migrating v4 to v5 i hope it will settled soon everything and goose smooth.
v 5 is meager upgrade.
test and to be fixed step by step
some one written in this forum with frustration please be cool
This is open source at least we help to test new version with positive attitude don’t use frustration lick words, we all anchorage and help the team to success
world class Indian erp and open source maybe it will tack sum time what’s wrong.
ERPNEXT team is small with big responsibility we need to help them.


Hello Chandu,

Many thanks for your response, I am just trying to install. And i did everything right, i don’t know what’s wrong :frowning:.

Apologies if i have mistaken. For me running any version will be fine, can i run older version ?



I nead to appreciate your boldness sincerity god bless you.
Yes V 4 very stable for production
i am using v4 from last financial year to till to data with out
problem with help erpnext forum
please test V 5 in local vm and and post your queries (it is beta)
and i am testing v5 in vm
yes ther is some problem in fist setup
please don’t stop testing v 5 it is new baby need to help it

Thanks a lot Chandu for your help, but can i install Version 4 from web…i am looking for in Github for the code…though now

I have installed ERP next from here, GitHub - frappe/bench: CLI to manage Multi-tenant deployments for Frappe apps it points to ERP NEXT 4 i guess, can you please help me if its not 4 to get the 4 version.

Setup seems working for us. Can you reproduce the steps you used to get to this error?

Also, make sure that you’re on the latest codebase

bench switch-to-develop
bench update

Hello, I have installed ERP NEXT using this Commands : wget
sudo bash

Than logged it was showing on Redis on bench start, on some lines, removed that lines, that bench start worked.

Than on the login screen logged in using the Admin password from the text file and inputted the information, than it was hanging for hours with the information.

Can you please help me what might be wrong.

Many thanks for all of your help. Really great.

Replied below Mehta details on what i did

Okay, looks correct. Can you update using the commands I sent and check if it works for you (code on is the same as what you run)?

yeah did that too same Pratik…Can you please help me. It says ERP next installed successfully,

When i input the Company Setup Information, it gives below message,

and stuck on setup screen here,

for hours. Is there any configuration error, such as default mail didn’t setup or code running error?

I have spend a lot time on this but unfortunately couldn’t fix the issue yet. It would be very kind of you if you help out.

Best Regards


Hello Guys,
Moreover i have found that, when i am setting up only frappe there isn’t any problem with the framework. But when I am setting up ERPNEXT from the UI button here,

its creating the previous problem. Do i need to do any setting here on the frappe framework to go to ERPNEXT installation next ?

Best Regards


I too am having similar problems setting up a clean install of erpnext.
I am trying to run

bench setup supervisor 

but it is giving me an error saying

Permission denied: 'frappe-bench/logs/bench.log'

delete this log file, i solved this with this way