Can't edit website theme in production


I can’t edit my website theme in my production server, but it works great in my developement server with exactly the same versions of frappe/erpnext (checked with git log), the same databases (backup restore) and the same user (Administrator).

Here is the screenshot with the production server on the left and developement environment on the right. In the production server, I don’t have the blue Save button on the upper right, neither the link box for bootstrap CSS and so on.


Have you run bench clear-cache, bench sync-www ?

Dev server refreshes after every change, production does not.

I have run :
bench clear-cache
bench clear-website-cache
bench restart

Not bench sync-www because i don’t use www folder for web pages, but i will
try anyway.


I have just tried =>

ERPNext:~/frappe-bench$ bench clear-cache ERPNext:~/frappe-bench$ bench clear-website-cache ERPNext:~/frappe-bench$ bench sync-www ERPNext:~/frappe-bench$ bench restart frappe-bench-frappe-async-worker: stopped frappe-bench-frappe-longjob-worker: stopped frappe-bench-frappe-workerbeat: stopped frappe-bench-frappe-web: stopped frappe-bench-frappe-worker: stopped frappe-bench-node-socketio: stopped frappe-bench-frappe-async-worker: started frappe-bench-frappe-longjob-worker: started frappe-bench-frappe-workerbeat: started frappe-bench-frappe-web: started frappe-bench-frappe-worker: started frappe-bench-node-socketio: started

But it is still the same, I think it is a display mode because the UI has some differences in the joined screenshot.

If I try to duplicated the theme, I get the message
“Not allowed to create Website Theme”

But if I check roles, I’m admin and “Create” is well checked

I have just updated to the last master branches of bench/frappe/erpnext but I still have the problem on my production server and it is still working on my development env.

I notice another strange thing : some icons are not translated on my production server but all is ok on my developement machine. It is “Tools”, “File Manager”, “Human Resources”, “POS”
, “Learn” and “Developer”.

I have the same code for bench/frappe/erpnext and the same translations files on both servers.

@britlog no no no no, the problem is not like this, i think you have made modifications in this doctype because it shouldn’t be a submitted file type but in your production it is submitted with no amend privileges…

as for the labels translation i think a fix will be soon pushed…

@max_morais_dmm & @rmehta the translation is the same as mine advised in :

@ramielian I have just done this in my production server and now my desk icons are well translated =>

bench build
bench build-website
bench migrate

Hope it will work for you too

I 've just found my problem : I was not in developer mode in my production server !!
I added developper mode in my site_config.json file and now I can edit my standard website theme.
So I will let the developer mode in production, is there any downsides to do so ?
Is it normal behavior to lock website themes editing without developer mode enabled ?


@britlog as i told you the document is submitted not only saved, you can change the doctype format and disable submit ed permission from it and take out development mode because development mode is not always stable and if you need stability you need production mode only…

the development mode will download some files that are still in beta / devlop which in some cases are not stable for production servers…

@britlog unfortunatelly it didnt work

Hi Guy,

I have faced same issue.

Anybody have solution for same.


As mentioned here:

have you tried the turn on developer_mode?

bench --site sitename set-config developer_mode 1

Hi @rahy,

I have already set developer mode 1 in my site_config.json file but not working properly.
Issue: werkzeug.exceptions.NotFound: 404 Not Found: The requested URL was not found on the server. If you entered the URL manually please check your spelling and try again.
Thanks for replay.

Thank you so much.