Custom Checkbox Disabled For New DocTypes

I am trying to add a new DocType that I don’t want to be “custom” however no matter what I do, the checkbox is disabled and checked. Looking at the forum, the common problems seem to be either the site isn’t in development mode or the user logged in isn’t an administrator. But neither of these are the case for me.

I have enabled developer mode as follows:

bench set-config -g developer_mode 1

And confirmed that the ~/frappe-bench/sites/common_site_config.json file and my ~/frappe-bench/sites/site.local/site_config.json files have it set to 1:

    "developer_mode": 1

After changing this, I cleared the cache as such:

bench --site site.local clear-cache

And as good measure, in the web browser selected Reload from the menu. But still no luck. I then restarted my docker container to see if that did anything. No luck. I saw a comment somewhere else where someone recommended doing a bench build but trying that didn’t do anything.

I pasted a screenshot below. It seems Frappe is recognizing it’s in developer mode because of the message it is displaying at the top. And I am logged in as an administrator. But I can’t get that custom checkbox to be enabled.

Is there something I am missing? Any suggestions on what else to try?

Hi @fiveoaks:

Are you logged as an admin privileged user or … with “Administrator” user?

I’m logged in as the Administrator user which I created upon setup. I would assume that they are also the admin privileged user but how would I check that?

It’s the right user :slight_smile:
Try bench --site site.local migrate

Tried that but no luck. Still disabled.

Hi @fiveoaks,

Can you give it a try?
please restart the bench. This means stop the bench and then again start the bench. check it.

Thank You!

I tried that but also no luck. I ended up deleting my database, deleting all the files, and rebuilding the docker container and setting it up again. It’s working now. Not a huge deal since this was just a test environment however a little concerning.

I had this happen again and have found a pattern. Maybe it’s my misunderstanding or maybe it’s a bug. The account that I am initially setting up during the install which I believe is the administrator account, really isn’t or it’s somehow losing it’s administrator properties. See my post Administrator Account: Is this an issue or expected behavior?