Custom endpoints inside redis conf files

How redis_cache.conf, redis_queue.conf, redis_socketio.conf should looks if I want to use redis endpoint from the remote server (redis ip address) or amazon elasticache redis instance endpoint.
I supose I need to have port and endpoint (bind)…but it doesn’t work with…

There is no bench command to update redis endpints like we have for database?

I can connect to my remote redis instance using redis-cli but from app not

Try this but without success


I know this is old but, I managed to use remote Redis servers on AWS (I think). By creating 3 Redis instances listening to ports (in my case) [11000,12000,13000]. You should also modify the common_site_config.json and add the Redis host (or endpoint). To verify it was working, I blocked traffic to my Redis nodes (remote), disabled the Redis service in the local production server and rebooted it. Next, I tested accessing the website, the web page didn’t load.
I then allowed access to my Redis nodes (remote) again from my production instance and the webpage started loading and working properly again.
What I need now is to formally confirm the function of the different Redis servers is being fulfilled.
If you need more details on how I managed to do this please contact me.

1 Like

Is it possible to reuse a single Redis instance but with 3 different “databases”? (I don’t know if there’s such concept, or even if it exists, supported by Frappe)

Hello did you manage to get a solution?

There’s bench command to modify common_site_config.json

bench set-mariadb-host mariadb
bench set-redis-cache-host redis-cache:6379
bench set-redis-queue-host redis-queue:6379
bench set-redis-socketio-host redis-socketio:6379

SELECT | Redis says:

In practical terms, Redis databases should be used to separate different keys belonging to the same application (if needed), and not to use a single Redis instance for multiple unrelated applications.

When using Redis Cluster, the SELECT command cannot be used, since Redis Cluster only supports database zero

1 Like

Hi everyone!
I am trying to setup ERPNext locally on my computer using frappe docker. I am able to connect with AWS RDS but this is not the case for AWS ElastiCache. I am setting values for REDIS In this way.
REDIS_CACHE: ***use1.cache.amazonaws-com:6379/0
REDIS_QUEUE: ***use1.cache.amazonaws-com:6379/1
REDIS_SOCKETIO: ***use1.cache.amazonaws-com:6379/2
Is this the right way to connect to AWS ElastiCache? It’s not working what are your suggessions?