Custom field bug

I followed this guide exactly but when trying to get project_name into my sales invoice with {{ doc.project_name }} it just says “None” on the invoice.

Is the fetch pulling the project_name through? Would be helpful to know if the issue is with the fetch or the jinja code. Everything looks ok from your post though :thinking:

Hi @Rick-Hard89,

If the version is not updated then please update it and migrate it.
It’s worked on the below version.

# Vesion
ERPNext: v14.31.3 (version-14)
Frappe Framework: v14.41.0 (version-14)

Thank You!

I’m on a fresh install of frappe(14.42.0) and erpnext (14.32.1), also have some other modules installed. Yesterday i tried to do a bench migrate but it was still the same.

Today when i tried making a new timesheet and chose the project the project name showed up for some reason even though i also did the same yesterday without it showing up. Now it’s working correctly and it’s also showing on the invoice.
But i also have another strange problem with my ERPNext, the sales tax on items disappears when i save the invoice. Another person also have the same problem on this forum. Could it be something with the newer version I’m using?
Thank you very much for the help!

Link to his thread:

I suspect it was the module POSAwesome that had something to do with the problems we had. All works well now that i reinstalled it without that module