Decimals issues again


I thought I had decimals working fine at least, but today doing an invoice I realice I didn’t.

I know you can edit the TAX manually, but there has to be another way. Imagine you are doing an invoice on a shop and before doing the bill, you have to take out your calculator machine, modify the invoice, etc., while your clients are waiting for you…

Aren’t you having these issues?

What am I doing wrong in here?

21% of 1001,8000000 is not 210,39 is 210,378

Thanks in advance for your kind help, as always and kind regards from Spain

I think this topic may be related:

In version 4, all the calculations are done in your company currency. Hence, system first calculate item amount in company currency based on exchange rate and then calculate tax on it. After doing the calculation, it again converts all the totals in customer’s currency, it leads to some divisional loss.

In version 5, all the calculations will be on customer’s currency, hence I think it will solve the issue. I am working on this currently.

Hi nabinhait and info,

Thanks for your replies.

Nabinhait, I am looking forward to the new release and your new solution.

Thanks and kind regards,


It’s me again with this issue.

I don’t know if it is because I do not input invoices very often, but every time I try to do it I find this issue again!?

I thought it was solved, or it is me that I am doing something wrong?

I am on v7 development.

In this example, what may I be doing wrong?

21% of 278,10 is 58,401 that it is veeery different from 58,41

Is anybody having issues like this?

Many thanks and kind regards,


hi @pagliaso

are you going for item wise tax or on net total?

Hi spa,

Many thanks for your reply, and sorry for my slow reply, I am having someissues with my server.

I am going for tax on net total

Thanks and kind regards,



It’s me with the decimals again!

Is me the only having issues with the decimals on tax calculations on net total??

This can’t be right.

As I was taught to make roundings this should be 183,84, not 183,85. It is the same with any precision setting.

I must have something badly configured, if not I can’t understand that there aren’t more users complaining about the same.

I have rate for the tax configured as Percent Value, but I have tried with currency and float with the same results. I am on:
ERPNext: v8.x.x-beta (51cd2df) (develop)
Frappe Framework: v8.x.x-beta (da1ade6) (develop)

If someone could share how they have their setting and if they are getting consistent calculations on the taxes I would be very grateful.

Many thanks and kind regards,