Easiest & Simple Way to Install ERPNext 13

Tried ERPNext Easy install on many platforms such as Google Cloud Platform (GCP), Vultr etc. and came up with either Mariadb dependency errors or localhost unable to connect and consequently unable to start Mariadb. Digital Ocean (DO) seems to be the most beginner friendly to run the easy install script.

  1. Create a DO account.

  2. Create a Droplet of your choosing. For this instance I chose, Ubuntu 20.04 (LTS) x64
    (2 vCPUs | 4GB RAM | 80GB Disk).

  3. Login to Console or use Putty or any SSH console.

  4. You will be logged in initially as root user, this is the assumption.

  5. Add New User sudo adduser your-username, and complete the instructions to add user.

  6. Add the newly created user to the sudoers list sudo usermod -aG sudo your-username.

  7. Switch to the new user su - your-username.

  8. Update packages sudo apt update && sudo apt upgrade -y.

  9. Run Command export LC_ALL=C.UTF-8.

  10. Download File wget https://raw.githubusercontent.com/frappe/bench/develop/install.py.

  11. Run the Install file python3 install.py --verbose --production --user your-username --frappe-branch version-13 --erpnext-branch version-13 (Note: You can change the version you would like to install).

  12. Wait for the Install to complete. Estimated about 10-15 mins with 0 errors.

  13. During the Install process it will ask you to enter mysql & Administrator password.

  14. Once completed, go to your DO assigned IP Address and you will see a login screen.

  15. Enter the Username as ‘Administrator’ & Password that was entered during the install process for the Administrator user.

Common Issues Resolution:

Issue 1

launchpadlib 1.10.6 requires testresources, which is not installed.

Solution 1 (Thanks @Abhinav_Jain) launchpadlib - testsources


`sudo apt install python3-testresources`


`sudo apt install python-testresources`


this worked well, however, I got an “ERROR: launchpadlib 1.10.13 requires testresources, which is not installed” (this didn’t stop the installation though) on Ubuntu 20.04 minimal (1 vCPUs| 1 GB RAM 2GB swap| 50 GB disk). And the installation aborted at later stages (not sure if it was because of the RAM but was not able to capture the error). I re entered the installation command after installing testresources (here). And manage to complete the setup without error and managed to get ERPNext 13 running.

Suggestion: Please also add that the ports have to be opened in ubuntu firewall. It took me sometime to figure out why my installation is not working.

1 Like

Did you run it on Digital Ocean?
I used to get that error on GCP.

I had no port issues in DO at least. in Vultr and GCP I had port issues.

Kindly elaborate here on your steps on how you openes the ports, for the benefit of the community. I might add it in the original post as well.


Hi @Calibr3,

I tried it on Oracle Cloud for hobby purposes. Oracle is currently giving 2 Always free VMs (1vCPU | 1 GB each and total 200 GB storage). I opened port 80 and made it persistent using (also have to open it in the firewall based on the installation):

sudo iptables -I INPUT 6 -m state --state NEW -p tcp --dport 80 -j ACCEPT
sudo netfilter-persistent save

In case someone is interested in Oracle cloud, have a look at this article on launching a Wordpress instance on free tier link. I can confirm that I was able to install ERPNext v13 on it. The performance was good as well and way better that GCP.


Thank you for the information. 1 vcpu is actually too less for ERPNext. 2 or more is preferred. Min 4 GB is also needed. Will check out the link.

1 Like

I was able to install on 1vCPU and 1GB Ram, (added 1GB swap) using docker.
It is the capacity of free tier given by most cloud providers. It works good enough for 1-2 user system to begin using ERPNext.

1 Like

Is the Docker Container installation better than regular installation?

I am using it for more than a year now.

I’ve installed it for more than 35 sites for others.

Vm with 1vcpu and 1+1 gb ram+swap can run docker based ERPNext setup.

The only drawback is, if you ask question on forum it is assumed you’re not using docker. I’ll be only one of the few to reply docker related questions.


In case of localhost errors during installation.

This should help. Thanks @Abhinav_Jain localhost resolution

sudo iptables -I INPUT 6 -m state --state NEW -p tcp --dport 80 -j ACCEPT

sudo netfilter-persistent save

1 Like

Just tried the Oracle install. Thanks @Abhinav_Jain & @revant_one for the info. Didn’t realize Oracle had an always free 1GB VM.

1 Like

I use OCI Always Free for non ERPNext purposes. I notice there are some SQL , and nosql database options, including Always Free Autonomous Transaction Processing databases. Has anyone attempted to use any of those with Frappe?

I was thinking the same but I am a Linux noob. If someone can try out the free SQL resources with ERPNext then OCI can be a frugal solution for hosting ERPNext

Oracle also gives 4 vCPU & 24 GB RAM arm64 instances under its Always free program. It can be useful if someone can try it out and post a tutorial here.

1 Like

Ya I just checked, ya you’re right, with those free specs. But they only work with the Oracle Linux Image.

Strange, I am able to select Ubuntu 20.04 and prior versions as well (only the minimal versions are not selectable).

A few weeks ago I installed CapRover on this VM with Ubuntu OS without any issue. The specs are just too good to ignore.

You’re right!

I just assumed Ubuntu in itself wouldn’t work as the default selected was minimal. Didn’t think about changing the image versions.

BTW, I tried installing on the stack as mentioned above.
It Works!

Thank you for this.

The site installed is site1.local. If I want another site name, would it be the best to change
it after the install ?I found a few posts about changing site-names . They were for rather
older versions of ERPNext, but should still work ??

Hello, I want install ERPNext to test School system with free tier OCI Ampere 4/24. I tried many times without success.
Do you give me the procedures o script install please.

Rene Zamora

EDIT: Works fine with script in first post + testresources + opened port 80, but this is my view

With respect ot OCI, I was wondering if anyone had tried the Kubernetes cluster in Developer Services with a VM.Standard.A1.Flex Shape? I hope @revant_one won’t mind a ping?