Email Domain Setup - Stuck One Saving

Hello All,
I have tried this on multiple servers, (local Server, Digital Ocean server and one more cloud server)
Email Domain gets stuck when trying to add zoho domain.
it works fine on gmail domain.

It was a problem in erpnext with zoho but it was fixed. But i think its the same problem again.

Can anyone check with this ? Sometime the email domain replies with outgoing server is wrong.

Not sure this helps but using the Vm I found the config wouldn’t get saved and the solution was rlto use the mail server ip address instead. Obviously there is a bug or issue with dns lookups out of the box with the VM.
Might give you some clues at least …


I will try this now.

Static IP of the and works fine.



Hi @fkardame! I have the same issue, but whit any mail (google for example).

Email Domain gets stuck when trying to save.

Any sugestion?

I am runing 7.2.29 (the last version)


1 Like

Either you didnt install it properly.
or There is some other issue. I had that problem in my v6 version.
Try using static IP of that email for example is for in my region.
Hope this helps.

1 Like

Hi, please share the static IP you used for imappro and smtp for zoho
I read on zoho forum that zoho mail ip is not fixed and they change it sometimes.
has it been a problem you faced or is it working fine?


I’ve tried using the following IP Address for for

it says outgoing email account not correct

please help

Tick always use email address as login
And check if the ip address are correct. Try to use imap.zoho.coms ip address instead of imappro.

Yup neither responds to ping whereas gmail does (for example)

frappe@erpnext:~/frappe-bench$ ping
PING ( 56(84) bytes of data.
^C ping statistics —
13 packets transmitted, 0 received, 100% packet loss, time 11999ms

frappe@erpnext:~/frappe-bench$ ping
ping: unknown host
frappe@erpnext:~/frappe-bench$ ping
PING ( 56(84) bytes of data.
64 bytes from ( icmp_seq=1 ttl=44 time=31.6 ms
64 bytes from ( icmp_seq=2 ttl=44 time=32.1 ms
^C ping statistics —
2 packets transmitted, 2 received, 0% packet loss, time 1001ms

So you need to confirm connect info for

I’ve set the same email in apple mail and it works fine (imappro and smtp)

Yes i just pinged imappro imap and SMTP of zoho. It return with request time out.

But i tested email service is working fine.

This is strange. I tried what’ and found these.

Try using these. If this helps

If these doesn’t work then contact zoho.

Received this response from zoho

Please find the IPs for our IMAP and SMTP servers below,
We would like to keep you informed that the IPs corresponding to the IMAP and SMTP servers are subject to change. Hence we request you to use the hostnames directly instead of using the IPs corresponding to them.
Also we would like to inform you that we have intentionally blocked the ping requests to our servers. Hence the packet loss. Instead of pinging the servers, you may run a OpenSSL test to check the connectivity.

I’ve already tried these IPs and unable to find a solution to set up email domain. Would really like to know a fix.

This test confirms connectivity to zoho’s mail service (from within my local network LAN)-

[clarkej@sierra ~]$ nc -vv 993
Ncat: Version 6.40 ( Ncat - Netcat for the 21st Century )
libnsock nsi_new2(): nsi_new (IOD #1)
libnsock nsock_connect_tcp(): TCP connection requested to (IOD #1) EID 8
libnsock nsock_trace_handler_callback(): Callback: CONNECT SUCCESS for EID 8 []
Ncat: Connected to

[clarkej@sierra ~]$ nc -vv 587
Ncat: Version 6.40 ( Ncat - Netcat for the 21st Century )
libnsock nsi_new2(): nsi_new (IOD #1)
libnsock nsock_connect_tcp(): TCP connection requested to (IOD #1) EID 8
libnsock nsock_trace_handler_callback(): Callback: CONNECT SUCCESS for EID 8 []
Ncat: Connected to

To debug your failed connectivity case: Run the above connectivity test, start from the server that hosts ERPNext. At some server ‘node’ a port is closed - for example your gateway router? - that port must opened that prevents mail service connectivity.

hope this helps shikher

I think I found the problem.

Google cloud doesn’t allow 587 and 465. Have to use mailjet/mailgun/sendgrid

any suggestions on which one should I use? mailjet seems to offer a lot more options (including custom domain) than any other. although highest free emails are on mailgun.

also, is there a guide to install postfix mail on ubuntu?

Sorry I have no experience so can’t comment on either topic.

For an ERPNext instance I skip the bare install hoops, to download instead an ova image - the VM includes a working Postfix MTA right out of the box!

Postfix was already installed. setting up mailjet. will post here the process. Thanks everyone. :slight_smile:

I am using zoho mail.
Email setting works on tls only for zoho.

but i am getting emails which are generated automatically at midnight. all employees are getting daily emails but when i try to send the quotation or purchase order via Email button it does not send but somethings when i close the communication manually and reopen and link it. its sends after long time.

I had installed postfix manually. I dont understand what can be the issue here. As auto emails are working but manual email of quotation or purchase order or any document which i try to send via email doesnt work.

Any one aware of such kind of issue?

Hi Shikher,
did you succeed in setting up mailjet with your Gcloud instance ?
If so, can you share your postfix/erpnext conf ?
Thanks !

No, I tried the google’s steps on setting mailjet but it did not work.
Would like to test suggestion if anyone can provide.


My recomendation is to use sparkpost, mailjet or turbosmtp for outgoing mails in erpnext as it will put your business email into blacklist and turn it into spam.