Email Inbox desktop icon missing


I have created several email accounts and a domain.

I have explicitly given a user an email inbox, and on the desk homepage, email inbox doesn’t show up.

I can search for “open email inbox” and it opens communications.

Am I missing something?

According to this: Email Inbox shows up in 7.2.29 - #2 by makarand_b
It has been removed, and it is under communications now. However, when I go to settings I don’t see communications. I can only open inbox by SEARCHING for it… I think the workflow for this has been broken.

Same bug here. Pretty sure it is broken.

One overkill solution could be to create a custom app and add a link in config/ to List/Communication, that redirects to the mailbox.

I have noticed the same as well. Any possible solution?

Hey @Reese_Jenner,
the email inbox is not missing, it’s in the module CRM -> Communication (and then you can click on email inbox in the sidebar).

Hope this helps you!


Thank you. It clears it up.


Hi @P-Froggy,

On my installation, I am not able to view/see/read received emails including replies.

Thanks for the tip. Is there a setting that needs to be done for the email account? In my sidebar I only see one email account – the one that is actually disabled – but not the active email one.

To be sure, the Sent emails is there on the sidebar, and is populated correctly.

@Sinethemba_Gayiza & @laurence, have you also linked the email accounts which you want to access in the user master?

See here:

That’s it! Thanks.

but how do u get notificaiotnt then ?

but how do u know if u got a new email o ?

Same Problem here, new Installation. Everything nice only no email ICON anywhere… Maildomain ok, Mailaccount ok, SSL activated. SMTP working but no INBOX functions. Is there something to do, after all? Ah, the users are mapped to the mail accounts.

I don’t know on which version of ERPNext you are, but as far as I’m aware, there is no specific email icon anymore since V11 or 12. Just open communication, and you should be able to select Inbox in the drop-down list at the top:


Just make sure that the current user has an inbox assigned under his profile and the required role assigned.

erpnext@erp:/opt/bench/erpnext$ bench version --format plain
erpnext 14.x.x-develop develop (ae35339)
frappe 15.x.x-develop develop (052a252)

are this newest versions? should i use not develop?

User is assigned to all roles. There is a email account connected to him. Communication is not in main menu i only can reach it through search alltough…

Next Problem, no mails beeing fetched by IMAP…

The communication Doctype is listed under the CRM section if I’m not mistaken.