ERP showing only E Logo

I have updated my system today and after update when I login I can only see a big E logo on the screen. Following errors were there on the JS console.
Navigated to
desk.min.js:899 Uncaught SyntaxError: Unexpected token return
list.min.js:1 Uncaught TypeError: Cannot set property ‘listing’ of undefined
at list.min.js:1
(anonymous) @ list.min.js:1
form.min.js:1 Uncaught TypeError: Cannot set property ‘grid_form’ of undefined
at form.min.js:1
(anonymous) @ form.min.js:1
report.min.js:1 Uncaught TypeError: Cannot read property ‘Factory’ of undefined
at report.min.js:1
(anonymous) @ report.min.js:1
erpnext.min.js:1 Uncaught TypeError: frappe.provide is not a function
at erpnext.min.js:1
(anonymous) @ erpnext.min.js:1

Kindly let me know how can I correct this?



fixed via [minor] fixes in multiline string in upload.js by mbauskar · Pull Request #3041 · frappe/frappe · GitHub

I was having the same problem . please update to latest version . it has been fixed now

i was having the same error even i tried to reinstall the app but all in vain…

then i tried “bench watch”…and it worked like a silver bullet.

should try this even if it stuck some where just abort it using ctrl+c.



Thanks @mubashshir @adnan . After update and “bench watch”, the system is working.


Beta instance at seems to be having the same issue

Firefox console output:

SyntaxError: missing ; before statement desk.min.js:899:878
TypeError: frappe.templates is undefined list.min.js:1:1
TypeError: frappe.templates is undefined form.min.js:1:1
TypeError: frappe.views is undefined report.min.js:1:1
unreachable code after return statement erpnext.min.js:214:709
TypeError: frappe.provide is not a function erpnext.min.js:1:1