ERPnext installation on CentOS 6.7 with Plesk

Hello everyone,

ERPnext installed like a charm on my dev server running Ubuntu using the installation script and bench.

Unfortunately, I could not deploy it on my production server running CentOS with Plesk.

Here is the process I followed:

Initially, the install script that also installs all prerequisites failed, so I tried to upgrade several packages such as MySQL from 5.1 to 5.5 with MariaDB. Luckily I have all Python 2.7 with libs installed (I am moving from Odoo).
At nginx I stopped because my installation has a sw-nginx package installed that conflicts. I preferred to avoid uninstalling this and installing nginx from fresh cause I don’t want to ruin the Plesk installation and I am not very familiar with nginx.

Thus I decided to install from source. I downloaded bench from git and installed manually. The installation was straightforward without any errors. Even created my first site with:

bench init mysite

The issue I now have is that bench start (wanted to see if it works on the dev mode first) would not work. It gives my the following error:

20:03:51 workerbeat.1 | celery beat v3.1.20 (Cipater) is starting.
20:03:51 socketio.1 |
20:03:51 socketio.1 | events.js:72
20:03:51 socketio.1 | throw er; // Unhandled ‘error’ event
20:03:51 socketio.1 | ^
20:03:51 socketio.1 | Error: listen EADDRINUSE
20:03:51 socketio.1 | at errnoException (net.js:883:11)
20:03:51 socketio.1 | at Server._listen2 (net.js:1021:14)
20:03:51 socketio.1 | at listen (net.js:1043:10)
20:03:51 socketio.1 | at Server.listen (net.js:1109:5)
20:03:51 socketio.1 | at Object. (/var/www/vhosts/
20:03:51 socketio.1 | at Module._compile (module.js:456:26)
20:03:51 socketio.1 | at Object.Module._extensions…js (module.js:474:10)
20:03:51 socketio.1 | at Module.load (module.js:356:32)
20:03:51 socketio.1 | at Function.Module._load (module.js:312:12)
20:03:51 socketio.1 | at Function.Module.runMain (module.js:497:10)
20:03:51 system | socketio.1 stopped (rc=8)

I have checked and the default port (8000) I am using if free.
fuser -v -n tcp 8000

Something else I noticed is that I cannot start bench from other directory that frappe-bench. If I try to, I get the following error:

[28858] [ERROR] Procfile does not exist or is not a file

…which is weird because that does not happen on my Ubuntu dev server.

At this point it seams I am stuck as no matter what I do (followed some advise about nginx at the forum) would not work.

Anyone tried installation on a CEntOs server with Plesk before? Would you suggest I remove sw-nginx and install nginx package without ruining Plesk’s setup? Anything else I could look at as a hint?

Thank you in advance,